summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-numpy_1.22.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-numpy_1.22.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-numpy_1.22.2.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-numpy_1.22.2.bb b/meta/recipes-devtools/python/python3-numpy_1.22.2.bb
new file mode 100644
index 0000000000..ba0a777551
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-numpy_1.22.2.bb
@@ -0,0 +1,63 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2HOMEPAGE = "https://numpy.org/"
3DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python."
4SECTION = "devel/python"
5LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8026691468924fb6ec155dadfe2a1a7f"
7
8SRCNAME = "numpy"
9
10SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
11 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
12 file://0001-numpy-core-Define-RISCV-32-support.patch \
13 file://run-ptest \
14 "
15SRC_URI[sha256sum] = "093d513a460fd94f94c16193c3ef29b2d69a33e482071e3d6d6e561a700587a6"
16
17UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
18UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
19
20DEPENDS += "python3-cython-native"
21
22inherit ptest setuptools3
23
24S = "${WORKDIR}/numpy-${PV}"
25
26CLEANBROKEN = "1"
27
28do_compile:prepend() {
29 export NPY_DISABLE_SVML=1
30}
31
32FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
33
34# install what is needed for numpy.test()
35RDEPENDS:${PN} = "${PYTHON_PN}-unittest \
36 ${PYTHON_PN}-difflib \
37 ${PYTHON_PN}-pprint \
38 ${PYTHON_PN}-pickle \
39 ${PYTHON_PN}-shell \
40 ${PYTHON_PN}-doctest \
41 ${PYTHON_PN}-datetime \
42 ${PYTHON_PN}-distutils \
43 ${PYTHON_PN}-misc \
44 ${PYTHON_PN}-mmap \
45 ${PYTHON_PN}-netclient \
46 ${PYTHON_PN}-numbers \
47 ${PYTHON_PN}-pydoc \
48 ${PYTHON_PN}-pkgutil \
49 ${PYTHON_PN}-email \
50 ${PYTHON_PN}-compression \
51 ${PYTHON_PN}-ctypes \
52 ${PYTHON_PN}-threading \
53 ${PYTHON_PN}-multiprocessing \
54 ${PYTHON_PN}-json \
55"
56RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \
57 ${PYTHON_PN}-hypothesis \
58 ${PYTHON_PN}-sortedcontainers \
59 ${PYTHON_PN}-resource \
60 ldd \
61"
62
63BBCLASSEXTEND = "native nativesdk"