summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-numpy_1.22.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-numpy_1.22.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-numpy_1.22.0.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-numpy_1.22.0.bb b/meta/recipes-devtools/python/python3-numpy_1.22.0.bb
new file mode 100644
index 0000000000..556e2dd5c9
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-numpy_1.22.0.bb
@@ -0,0 +1,60 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2HOMEPAGE = "https://numpy.org/"
3DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python."
4SECTION = "devel/python"
5LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b076ad374a7d311ba3126a22b2d52596"
7
8SRCNAME = "numpy"
9
10SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
11 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
12 file://0001-numpy-core-Define-RISCV-32-support.patch \
13 file://run-ptest \
14 file://0001-numpy-core-setup.py-disable-svml-for-now.patch \
15 "
16SRC_URI[sha256sum] = "f2be14ba396780a6f662b8ba1a24466c9cf18a6a386174f614668e58387a13d7"
17
18UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
19UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
20
21DEPENDS += "python3-cython-native"
22
23inherit ptest setuptools3
24
25S = "${WORKDIR}/numpy-${PV}"
26
27CLEANBROKEN = "1"
28
29FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
30
31# install what is needed for numpy.test()
32RDEPENDS:${PN} = "${PYTHON_PN}-unittest \
33 ${PYTHON_PN}-difflib \
34 ${PYTHON_PN}-pprint \
35 ${PYTHON_PN}-pickle \
36 ${PYTHON_PN}-shell \
37 ${PYTHON_PN}-doctest \
38 ${PYTHON_PN}-datetime \
39 ${PYTHON_PN}-distutils \
40 ${PYTHON_PN}-misc \
41 ${PYTHON_PN}-mmap \
42 ${PYTHON_PN}-netclient \
43 ${PYTHON_PN}-numbers \
44 ${PYTHON_PN}-pydoc \
45 ${PYTHON_PN}-pkgutil \
46 ${PYTHON_PN}-email \
47 ${PYTHON_PN}-compression \
48 ${PYTHON_PN}-ctypes \
49 ${PYTHON_PN}-threading \
50 ${PYTHON_PN}-multiprocessing \
51 ${PYTHON_PN}-json \
52"
53RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \
54 ${PYTHON_PN}-hypothesis \
55 ${PYTHON_PN}-sortedcontainers \
56 ${PYTHON_PN}-resource \
57 ldd \
58"
59
60BBCLASSEXTEND = "native nativesdk"