summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-numpy_1.21.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-numpy_1.21.5.bb')
-rw-r--r--meta/recipes-devtools/python/python3-numpy_1.21.5.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-numpy_1.21.5.bb b/meta/recipes-devtools/python/python3-numpy_1.21.5.bb
new file mode 100644
index 0000000000..bdf99b492b
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-numpy_1.21.5.bb
@@ -0,0 +1,59 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2HOMEPAGE = "https://numpy.org/"
3DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python."
4SECTION = "devel/python"
5LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b076ad374a7d311ba3126a22b2d52596"
7
8SRCNAME = "numpy"
9
10SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
11 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
12 file://0001-numpy-core-Define-RISCV-32-support.patch \
13 file://run-ptest \
14"
15SRC_URI[sha256sum] = "1a7ee0ffb35dc7489aebe5185a483f4c43b0d2cf784c3c9940f975a7dde56506"
16
17UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
18UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
19
20DEPENDS += "python3-cython-native"
21
22inherit ptest setuptools3
23
24S = "${WORKDIR}/numpy-${PV}"
25
26CLEANBROKEN = "1"
27
28FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
29
30# install what is needed for numpy.test()
31RDEPENDS:${PN} = "${PYTHON_PN}-unittest \
32 ${PYTHON_PN}-difflib \
33 ${PYTHON_PN}-pprint \
34 ${PYTHON_PN}-pickle \
35 ${PYTHON_PN}-shell \
36 ${PYTHON_PN}-doctest \
37 ${PYTHON_PN}-datetime \
38 ${PYTHON_PN}-distutils \
39 ${PYTHON_PN}-misc \
40 ${PYTHON_PN}-mmap \
41 ${PYTHON_PN}-netclient \
42 ${PYTHON_PN}-numbers \
43 ${PYTHON_PN}-pydoc \
44 ${PYTHON_PN}-pkgutil \
45 ${PYTHON_PN}-email \
46 ${PYTHON_PN}-compression \
47 ${PYTHON_PN}-ctypes \
48 ${PYTHON_PN}-threading \
49 ${PYTHON_PN}-multiprocessing \
50 ${PYTHON_PN}-json \
51"
52RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \
53 ${PYTHON_PN}-hypothesis \
54 ${PYTHON_PN}-sortedcontainers \
55 ${PYTHON_PN}-resource \
56 ldd \
57"
58
59BBCLASSEXTEND = "native nativesdk"