summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb b/meta/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
new file mode 100644
index 0000000000..68d8668a41
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
2HOMEPAGE = "https://github.com/cedadev/ndg_httpsclient/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://MANIFEST.in;md5=ce22c0cd986d2de3f7073cd6b5523ae0"
5
6SRC_URI[md5sum] = "b0fc8ea38f87d2c1ab1ed79a95c078f9"
7SRC_URI[sha256sum] = "d72faed0376ab039736c2ba12e30695e2788c4aa569c9c3e3d72131de2592210"
8
9inherit pypi setuptools3 update-alternatives
10
11PYPI_PACKAGE = "ndg_httpsclient"
12
13DEPENDS += " \
14 python3-pyopenssl \
15 python3-pyasn1 \
16"
17
18RDEPENDS:${PN} += " \
19 python3-datetime \
20 python3-logging \
21 python3-pyopenssl \
22 python3-pyasn1 \
23"
24
25BBCLASSEXTEND = "native nativesdk"
26
27UPSTREAM_CHECK_REGEX = ""
28
29ALTERNATIVE:${PN} = "ndg_httpclient"
30ALTERNATIVE_LINK_NAME[ndg_httpclient] = "${bindir}/ndg_httpclient"
31ALTERNATIVE_PRIORITY = "30"