summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-native_3.5.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.5.6.bb')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.6.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.6.bb b/meta/recipes-devtools/python/python3-native_3.5.6.bb
index 1e98c036c3..4c8faf88c0 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.6.bb
@@ -85,7 +85,11 @@ python(){
85 import json 85 import json
86 pythondir = d.getVar('THISDIR',True) 86 pythondir = d.getVar('THISDIR',True)
87 with open(pythondir+'/python3/python3-manifest.json') as manifest_file: 87 with open(pythondir+'/python3/python3-manifest.json') as manifest_file:
88 python_manifest=json.load(manifest_file) 88 manifest_str = manifest_file.read()
89 json_start = manifest_str.find('# EOC') + 6
90 manifest_file.seek(json_start)
91 manifest_str = manifest_file.read()
92 python_manifest = json.loads(manifest_str)
89 93
90 rprovides = d.getVar('RPROVIDES').split() 94 rprovides = d.getVar('RPROVIDES').split()
91 95