diff options
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.5.1.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-native_3.5.1.bb | 78 |
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.1.bb b/meta/recipes-devtools/python/python3-native_3.5.1.bb new file mode 100644 index 0000000000..152da1c5e2 --- /dev/null +++ b/meta/recipes-devtools/python/python3-native_3.5.1.bb | |||
@@ -0,0 +1,78 @@ | |||
1 | require recipes-devtools/python/python.inc | ||
2 | |||
3 | PR = "${INC_PR}.0" | ||
4 | PYTHON_MAJMIN = "3.5" | ||
5 | DISTRO_SRC_URI ?= "file://sitecustomize.py" | ||
6 | DISTRO_SRC_URI_linuxstdbase = "" | ||
7 | SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \ | ||
8 | file://12-distutils-prefix-is-inside-staging-area.patch \ | ||
9 | file://python-config.patch \ | ||
10 | file://000-cross-compile.patch \ | ||
11 | file://020-dont-compile-python-files.patch \ | ||
12 | file://030-fixup-include-dirs.patch \ | ||
13 | file://070-dont-clean-ipkg-install.patch \ | ||
14 | file://080-distutils-dont_adjust_files.patch \ | ||
15 | file://110-enable-zlib.patch \ | ||
16 | file://130-readline-setup.patch \ | ||
17 | file://150-fix-setupterm.patch \ | ||
18 | file://python-3.3-multilib.patch \ | ||
19 | file://03-fix-tkinter-detection.patch \ | ||
20 | file://avoid_warning_about_tkinter.patch \ | ||
21 | file://shutil-follow-symlink-fix.patch \ | ||
22 | file://0001-h2py-Fix-issue-13032-where-it-fails-with-UnicodeDeco.patch \ | ||
23 | file://sysroot-include-headers.patch \ | ||
24 | file://unixccompiler.patch \ | ||
25 | ${DISTRO_SRC_URI} \ | ||
26 | file://sysconfig.py-add-_PYTHON_PROJECT_SRC.patch \ | ||
27 | file://setup.py-check-cross_compiling-when-get-FLAGS.patch \ | ||
28 | " | ||
29 | SRC_URI[md5sum] = "e9ea6f2623fffcdd871b7b19113fde80" | ||
30 | SRC_URI[sha256sum] = "c6d57c0c366d9060ab6c0cdf889ebf3d92711d466cc0119c441dbf2746f725c9" | ||
31 | |||
32 | LIC_FILES_CHKSUM = "file://LICENSE;md5=dd98d01d471fac8d8dbdd975229dba03" | ||
33 | |||
34 | # exclude pre-releases for both python 2.x and 3.x | ||
35 | UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar" | ||
36 | |||
37 | S = "${WORKDIR}/Python-${PV}" | ||
38 | |||
39 | EXTRANATIVEPATH += "bzip2-native" | ||
40 | DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native" | ||
41 | |||
42 | inherit native | ||
43 | |||
44 | RPROVIDES += "python3-distutils-native python3-compression-native python3-textutils-native python3-core-native" | ||
45 | |||
46 | EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip" | ||
47 | |||
48 | EXTRA_OEMAKE = '\ | ||
49 | BUILD_SYS="" \ | ||
50 | HOST_SYS="" \ | ||
51 | LIBC="" \ | ||
52 | STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \ | ||
53 | STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \ | ||
54 | LIB=${baselib} \ | ||
55 | ARCH=${TARGET_ARCH} \ | ||
56 | ' | ||
57 | |||
58 | # No ctypes option for python 3 | ||
59 | PYTHONLSBOPTS = "" | ||
60 | |||
61 | do_configure_append() { | ||
62 | autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi | ||
63 | } | ||
64 | |||
65 | do_install() { | ||
66 | install -d ${D}${libdir}/pkgconfig | ||
67 | oe_runmake 'DESTDIR=${D}' install | ||
68 | if [ -e ${WORKDIR}/sitecustomize.py ]; then | ||
69 | install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN} | ||
70 | fi | ||
71 | install -d ${D}${bindir}/${PN} | ||
72 | install -m 0755 Parser/pgen ${D}${bindir}/${PN} | ||
73 | |||
74 | # Make sure we use /usr/bin/env python | ||
75 | for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do | ||
76 | sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT | ||
77 | done | ||
78 | } | ||