summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-maturin_1.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-maturin_1.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-maturin_1.5.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-maturin_1.5.1.bb b/meta/recipes-devtools/python/python3-maturin_1.5.1.bb
new file mode 100644
index 0000000000..96b046feba
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-maturin_1.5.1.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Build and publish crates with pyo3, rust-cpython, cffi bindings and rust binaries as python packages"
2HOMEPAGE = "https://github.com/pyo3/maturin"
3SECTION = "devel/python"
4LICENSE = "MIT | Apache-2.0"
5LIC_FILES_CHKSUM = "file://license-apache;md5=1836efb2eb779966696f473ee8540542 \
6 file://license-mit;md5=85fd3b67069cff784d98ebfc7d5c0797"
7
8SRC_URI[sha256sum] = "3dd834ece80edb866af18cbd4635e0ecac40139c726428d5f1849ae154b26dca"
9
10S = "${WORKDIR}/maturin-${PV}"
11
12CFLAGS:append = " -fdebug-prefix-map=${CARGO_HOME}=${TARGET_DBGSRC_DIR}/cargo_home"
13
14DEPENDS += "\
15 python3-setuptools-rust-native \
16 python3-semantic-version-native \
17 python3-setuptools-rust \
18"
19
20require ${BPN}-crates.inc
21
22inherit pypi cargo-update-recipe-crates python_pyo3 python_setuptools_build_meta
23
24do_configure() {
25 python_pyo3_do_configure
26 cargo_common_do_configure
27 python_pep517_do_configure
28}
29
30RDEPENDS:${PN} += "\
31 cargo \
32 python3-json \
33 rust \
34"
35
36RRECOMMENDS:${PN} += "\
37 python3-ensurepip \
38 python3-pip \
39 python3-venv \
40"
41
42BBCLASSEXTEND = "native nativesdk"