summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-maturin_1.4.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-maturin_1.4.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-maturin_1.4.0.bb b/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
new file mode 100644
index 0000000000..6f7cc6ef39
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-maturin_1.4.0.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Build and publish crates with pyo3, rust-cpython, cffi bindings and rust binaries as python packages"
2HOMEPAGE = "https://github.com/pyo3/maturin"
3SECTION = "devel/python"
4LICENSE = "MIT | Apache-2.0"
5LIC_FILES_CHKSUM = "file://license-apache;md5=1836efb2eb779966696f473ee8540542 \
6 file://license-mit;md5=85fd3b67069cff784d98ebfc7d5c0797"
7
8SRC_URI[sha256sum] = "ed12e1768094a7adeafc3a74ebdb8dc2201fa64c4e7e31f14cfc70378bf93790"
9
10S = "${WORKDIR}/maturin-${PV}"
11
12DEPENDS += "\
13 python3-setuptools-rust-native \
14 python3-semantic-version-native \
15 python3-setuptools-rust \
16"
17
18require ${BPN}-crates.inc
19
20inherit pypi cargo-update-recipe-crates python_pyo3 python_setuptools_build_meta
21
22do_configure() {
23 python_pyo3_do_configure
24 cargo_common_do_configure
25 python_pep517_do_configure
26}
27
28RDEPENDS:${PN} += "\
29 cargo \
30 python3-json \
31 rust \
32"
33
34RRECOMMENDS:${PN} += "\
35 python3-ensurepip \
36 python3-pip \
37 python3-venv \
38"
39
40BBCLASSEXTEND = "native nativesdk"