summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-magic_0.4.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-magic_0.4.20.bb')
-rw-r--r--meta/recipes-devtools/python/python3-magic_0.4.20.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-magic_0.4.20.bb b/meta/recipes-devtools/python/python3-magic_0.4.20.bb
new file mode 100644
index 0000000000..be3458a792
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-magic_0.4.20.bb
@@ -0,0 +1,21 @@
1SUMMARY = "File type identification using libmagic"
2DESCRIPTION = "This module uses ctypes to access the libmagic file type \
3 identification library. It makes use of the local magic database and supports \
4 both textual and MIME-type output."
5HOMEPAGE = "http://github.com/ahupp/python-magic"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=61495c152d794e6be5799a9edca149e3"
9
10PYPI_PACKAGE = "python-magic"
11
12inherit pypi setuptools3
13
14SRC_URI[sha256sum] = "0cc52ccad086c377b9194014e3dbf98d94b194344630172510a6a3e716b47801"
15
16RDEPENDS_${PN} += "file \
17 ${PYTHON_PN}-ctypes \
18 ${PYTHON_PN}-io \
19 ${PYTHON_PN}-shell"
20
21BBCLASSEXTEND = "native"