summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-license-expression_30.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-license-expression_30.3.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-license-expression_30.3.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-license-expression_30.3.0.bb b/meta/recipes-devtools/python/python3-license-expression_30.3.0.bb
new file mode 100644
index 0000000000..f36336b592
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-license-expression_30.3.0.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions"
2HOMEPAGE = "https://github.com/nexB/license-expression"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6
7SRC_URI[sha256sum] = "1295406f736b4f395ff069aec1cebfad53c0fcb3cf57df0f5ec58fc7b905aea5"
8
9inherit pypi ptest python_setuptools_build_meta
10
11DEPENDS += "python3-setuptools-scm-native"
12
13RDEPENDS:${PN} += "\
14 python3-booleanpy \
15 python3-core \
16 python3-json \
17 python3-stringold \
18 python3-logging \
19"
20
21BBCLASSEXTEND = "native nativesdk"
22
23SRC_URI += " \
24 file://run-ptest \
25"
26
27RDEPENDS:${PN}-ptest += " \
28 python3-pytest \
29 python3-unittest-automake-output \
30"
31
32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/tests
34 install -d ${D}${PTEST_PATH}/src
35 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
36 cp -rf ${S}/src/* ${D}${PTEST_PATH}/src/
37 cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
38}