summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-jsonschema_4.21.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-jsonschema_4.21.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-jsonschema_4.21.1.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-jsonschema_4.21.1.bb b/meta/recipes-devtools/python/python3-jsonschema_4.21.1.bb
new file mode 100644
index 0000000000..381148f4bb
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-jsonschema_4.21.1.bb
@@ -0,0 +1,50 @@
1SUMMARY = "An implementation of JSON Schema validation for Python"
2HOMEPAGE = "https://github.com/python-jsonschema/jsonschema"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \
5 file://json/LICENSE;md5=9d4de43111d33570c8fe49b4cb0e01af"
6
7SRC_URI[sha256sum] = "85727c00279f5fa6bedbe6238d2aa6403bedd8b4864ab11207d07df3cc1b2ee5"
8
9inherit pypi python_hatchling
10
11PACKAGES =+ "${PN}-tests"
12FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/jsonschema/tests"
13
14DEPENDS += "python3-hatch-fancy-pypi-readme-native python3-hatch-vcs-native "
15
16PACKAGECONFIG ??= "format"
17PACKAGECONFIG[format] = ",,,\
18 python3-idna \
19 python3-jsonpointer \
20 python3-webcolors \
21 python3-rfc3987 \
22 python3-rfc3339-validator \
23"
24PACKAGECONFIG[nongpl] = ",,,\
25 python3-idna \
26 python3-jsonpointer \
27 python3-webcolors \
28 python3-rfc3986-validator \
29 python3-rfc3339-validator \
30"
31
32RDEPENDS:${PN} += " \
33 python3-attrs \
34 python3-core \
35 python3-datetime \
36 python3-importlib-metadata \
37 python3-io \
38 python3-json \
39 python3-jsonschema-specifications \
40 python3-netclient \
41 python3-numbers \
42 python3-pprint \
43 python3-pyrsistent \
44 python3-referencing \
45 python3-zipp \
46"
47
48RDEPENDS:${PN}-tests = "${PN}"
49
50BBCLASSEXTEND = "native nativesdk"