summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-jsonpointer_2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-jsonpointer_2.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-jsonpointer_2.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-jsonpointer_2.4.bb b/meta/recipes-devtools/python/python3-jsonpointer_2.4.bb
new file mode 100644
index 0000000000..062fa5243f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-jsonpointer_2.4.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Resolve JSON Pointers in Python"
2HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3"
5
6inherit pypi ptest setuptools3
7
8SRC_URI[sha256sum] = "585cee82b70211fa9e6043b7bb89db6e1aa49524340dde8ad6b63206ea689d88"
9
10RDEPENDS:${PN} += " \
11 python3-json \
12"
13
14BBCLASSEXTEND = "native nativesdk"
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 python3-doctest \
22 python3-unittest \
23 python3-unittest-automake-output \
24"
25
26do_install_ptest() {
27 cp -f ${S}/tests.py ${D}${PTEST_PATH}/
28}