summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-jinja2_3.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-jinja2_3.1.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-jinja2_3.1.3.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-jinja2_3.1.3.bb b/meta/recipes-devtools/python/python3-jinja2_3.1.3.bb
new file mode 100644
index 0000000000..636fb35811
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-jinja2_3.1.3.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
2HOMEPAGE = "https://pypi.org/project/Jinja2/"
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
6
7SRC_URI[sha256sum] = "ac8bd6544d4bb2c9792bf3a159e80bba8fda7f07e81bc3aed565432d5925ba90"
8
9PYPI_PACKAGE = "Jinja2"
10
11CVE_PRODUCT = "jinja2 jinja"
12
13CLEANBROKEN = "1"
14
15inherit pypi setuptools3 ptest
16
17SRC_URI += " \
18 file://run-ptest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26RDEPENDS:${PN}-ptest += " \
27 python3-pytest \
28 python3-unittest-automake-output \
29 python3-toml \
30 python3-unixadmin \
31"
32
33RDEPENDS:${PN} += " \
34 python3-asyncio \
35 python3-crypt \
36 python3-io \
37 python3-json \
38 python3-markupsafe \
39 python3-math \
40 python3-netclient \
41 python3-numbers\
42 python3-pickle \
43 python3-pprint \
44 python3-shell \
45 python3-threading \
46"
47
48BBCLASSEXTEND = "native nativesdk"