summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-installer_0.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-installer_0.7.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-installer_0.7.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-installer_0.7.0.bb b/meta/recipes-devtools/python/python3-installer_0.7.0.bb
new file mode 100644
index 0000000000..9429705b1f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-installer_0.7.0.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Library and tool for installing Python wheels"
2DESCRIPTION = "A low-level library for installing a Python package from a wheel distribution."
3HOMEPAGE = "https://installer.readthedocs.io/"
4BUGTRACKER = "https://github.com/pypa/installer/issues"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=5038641aec7a77451e31da828ebfae00"
8
9SRC_URI += "file://interpreter.patch"
10
11SRC_URI[sha256sum] = "a26d3e3116289bb08216e0d0f7d925fcef0b0194eedfa0c944bcaaa106c4b631"
12
13inherit pypi python_flit_core
14
15# Bootstrap the native build
16DEPENDS:remove:class-native = "python3-build-native python3-installer-native"
17
18RDEPENDS:${PN} += " \
19 python3-compile \
20 python3-compression \
21 python3-netclient \
22"
23
24INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"
25
26do_compile:class-native () {
27 python_flit_core_do_manual_build
28}
29
30do_install:prepend:class-native() {
31 export PYTHONPATH="${S}/src"
32}
33
34BBCLASSEXTEND = "native nativesdk"