diff options
Diffstat (limited to 'meta/recipes-devtools/python/python3-hypothesis_6.61.0.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-hypothesis_6.61.0.bb | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-hypothesis_6.61.0.bb b/meta/recipes-devtools/python/python3-hypothesis_6.61.0.bb new file mode 100644 index 0000000000..204471c186 --- /dev/null +++ b/meta/recipes-devtools/python/python3-hypothesis_6.61.0.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | SUMMARY = "A library for property-based testing" | ||
2 | HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python" | ||
3 | LICENSE = "MPL-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c" | ||
5 | |||
6 | PYPI_PACKAGE = "hypothesis" | ||
7 | |||
8 | inherit pypi setuptools3 ptest | ||
9 | |||
10 | SRC_URI += " \ | ||
11 | file://run-ptest \ | ||
12 | file://test_binary_search.py \ | ||
13 | file://test_rle.py \ | ||
14 | " | ||
15 | |||
16 | SRC_URI[sha256sum] = "fbf7da30aea839d88898f74bcc027f0f997060498a8a7605880688c8a2166215" | ||
17 | |||
18 | RDEPENDS:${PN} += " \ | ||
19 | python3-attrs \ | ||
20 | python3-compression \ | ||
21 | python3-core \ | ||
22 | python3-json \ | ||
23 | python3-sortedcontainers \ | ||
24 | python3-statistics \ | ||
25 | python3-unittest \ | ||
26 | " | ||
27 | |||
28 | RDEPENDS:${PN}-ptest += " \ | ||
29 | ${PYTHON_PN}-pytest \ | ||
30 | " | ||
31 | |||
32 | do_install_ptest() { | ||
33 | install -d ${D}${PTEST_PATH}/examples | ||
34 | install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/ | ||
35 | install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/ | ||
36 | } | ||
37 | |||
38 | BBCLASSEXTEND = "native nativesdk" | ||