diff options
Diffstat (limited to 'meta/recipes-devtools/python/python3-hypothesis_6.122.6.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-hypothesis_6.122.6.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-hypothesis_6.122.6.bb b/meta/recipes-devtools/python/python3-hypothesis_6.122.6.bb new file mode 100644 index 0000000000..37eac3a1a5 --- /dev/null +++ b/meta/recipes-devtools/python/python3-hypothesis_6.122.6.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | SUMMARY = "A library for property-based testing" | ||
2 | HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python" | ||
3 | LICENSE = "MPL-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c" | ||
5 | |||
6 | PYPI_PACKAGE = "hypothesis" | ||
7 | |||
8 | inherit pypi setuptools3 ptest | ||
9 | |||
10 | SRC_URI += " \ | ||
11 | file://run-ptest \ | ||
12 | file://test_binary_search.py \ | ||
13 | file://test_rle.py \ | ||
14 | " | ||
15 | |||
16 | SRC_URI[sha256sum] = "2642598dc4426945d62b849a915d0d3e2d53f0fb17090f0cf10d8a545a421dc1" | ||
17 | |||
18 | RDEPENDS:${PN} += " \ | ||
19 | python3-attrs \ | ||
20 | python3-compression \ | ||
21 | python3-core \ | ||
22 | python3-json \ | ||
23 | python3-pytest \ | ||
24 | python3-sortedcontainers \ | ||
25 | python3-statistics \ | ||
26 | python3-unittest \ | ||
27 | python3-zoneinfo \ | ||
28 | " | ||
29 | |||
30 | RDEPENDS:${PN}-ptest += " \ | ||
31 | python3-unittest-automake-output \ | ||
32 | " | ||
33 | |||
34 | do_install_ptest() { | ||
35 | install -d ${D}${PTEST_PATH}/examples | ||
36 | install -m 0755 ${UNPACKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/ | ||
37 | install -m 0755 ${UNPACKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/ | ||
38 | } | ||
39 | |||
40 | BBCLASSEXTEND = "native nativesdk" | ||