summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-gitdb_4.0.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-gitdb_4.0.11.bb')
-rw-r--r--meta/recipes-devtools/python/python3-gitdb_4.0.11.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-gitdb_4.0.11.bb b/meta/recipes-devtools/python/python3-gitdb_4.0.11.bb
new file mode 100644
index 0000000000..25e1a2df7e
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-gitdb_4.0.11.bb
@@ -0,0 +1,22 @@
1SUMMARY = "A pure-Python git object database"
2HOMEPAGE = "http://github.com/gitpython-developers/gitdb"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=59e5ecb13339a936eedf83282eaf4528"
6
7DEPENDS = "python3-smmap"
8
9inherit pypi setuptools3
10
11PYPI_PACKAGE = "gitdb"
12
13SRC_URI[sha256sum] = "bf5421126136d6d0af55bc1e7c1af1c397a34f5b7bd79e776cd3e89785c2b04b"
14
15RDEPENDS:${PN} += "python3-compression \
16 python3-crypt \
17 python3-io \
18 python3-mmap \
19 python3-shell \
20 python3-smmap \
21"
22BBCLASSEXTEND = "native nativesdk"