summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-flit-core_3.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-flit-core_3.9.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-flit-core_3.9.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-flit-core_3.9.0.bb b/meta/recipes-devtools/python/python3-flit-core_3.9.0.bb
new file mode 100644
index 0000000000..b0bef4b6b6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-flit-core_3.9.0.bb
@@ -0,0 +1,37 @@
1SUMMARY = "This provides a PEP 517 build backend for packages using Flit."
2DESCRIPTION = "This provides a PEP 517 build backend for packages using \
3Flit. The only public interface is the API specified by PEP 517, at \
4flit_core.buildapi."
5HOMEPAGE = "https://github.com/pypa/flit"
6BUGTRACKER = "https://github.com/pypa/flit/issues"
7
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=41eb78fa8a872983a882c694a8305f08"
10
11SRC_URI[sha256sum] = "d75edf5eb324da20d53570a6a6f87f51e606eee8384925cd66a90611140844c7"
12
13inherit pypi python_flit_core
14
15# Need to install by hand as there's a dependency loop
16DEPENDS:remove:class-native = " python3-build-native python3-installer-native"
17DEPENDS:append:class-native = " unzip-native"
18
19# We need the full flit tarball
20PYPI_PACKAGE = "flit"
21PEP517_SOURCE_PATH = "${S}/flit_core"
22
23do_compile:class-native () {
24 python_flit_core_do_manual_build
25}
26
27do_install:class-native () {
28 python_pep517_do_bootstrap_install
29}
30
31PACKAGES =+ "${PN}-tests"
32
33FILES:${PN}-tests += "\
34 ${PYTHON_SITEPACKAGES_DIR}/flit_core/tests/* \
35"
36
37BBCLASSEXTEND = "native nativesdk"