summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dtschema_2024.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-dtschema_2024.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dtschema_2024.4.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dtschema_2024.4.bb b/meta/recipes-devtools/python/python3-dtschema_2024.4.bb
new file mode 100644
index 0000000000..9583cd57b9
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dtschema_2024.4.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Tooling for devicetree validation using YAML and jsonschema"
2HOMEPAGE = "https://github.com/devicetree-org/dt-schema"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=457495c8fa03540db4a576bf7869e811"
5
6inherit pypi python_setuptools_build_meta
7
8PYPI_PACKAGE = "dtschema"
9
10SRC_URI[sha256sum] = "18dd1d34b4a5e451291e5444e9ceb4a6febc605871cdaef22673b6f80aa4a131"
11
12DEPENDS += "python3-setuptools-scm-native"
13RDEPENDS:${PN} += "\
14 python3-dtc \
15 python3-jsonschema \
16 python3-rfc3987 \
17 python3-ruamel-yaml \
18 "
19
20BBCLASSEXTEND = "native nativesdk"