summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dtschema_2023.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-dtschema_2023.6.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dtschema_2023.6.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dtschema_2023.6.1.bb b/meta/recipes-devtools/python/python3-dtschema_2023.6.1.bb
new file mode 100644
index 0000000000..38ff2714f2
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dtschema_2023.6.1.bb
@@ -0,0 +1,15 @@
1SUMMARY = "Tooling for devicetree validation using YAML and jsonschema"
2HOMEPAGE = "https://github.com/devicetree-org/dt-schema"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=457495c8fa03540db4a576bf7869e811"
5
6inherit pypi setuptools3
7
8PYPI_PACKAGE = "dtschema"
9
10SRC_URI[sha256sum] = "d9dc11cea6a46ae2ee5ac4a5a1c7da7cb3704417cb390881820460f7c61eb784"
11
12DEPENDS += "python3-setuptools-scm-native"
13RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987"
14
15BBCLASSEXTEND = "native nativesdk"