summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-docutils_0.20.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-docutils_0.20.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-docutils_0.20.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-docutils_0.20.1.bb b/meta/recipes-devtools/python/python3-docutils_0.20.1.bb
new file mode 100644
index 0000000000..6038732cc4
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-docutils_0.20.1.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Docutils is a modular system for processing documentation into useful formats"
2HOMEPAGE = "http://docutils.sourceforge.net"
3SECTION = "devel/python"
4LICENSE = "PSF-2.0 & BSD-2-Clause & GPL-3.0-only"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=08f5f8aa6a1db2500c08a2bb558e45af"
6
7SRC_URI[sha256sum] = "f08a4e276c3a1583a86dce3e34aba3fe04d02bba2dd51ed16106244e8a923e3b"
8
9inherit pypi setuptools3
10
11do_install:append() {
12 for f in rst2html rst2html4 rst2html5 rst2latex rst2man \
13 rst2odt rst2odt_prepstyles rst2pseudoxml rst2s5 rst2xetex rst2xml \
14 rstpep2html
15 do
16 mv ${D}${bindir}/$f.py ${D}${bindir}/$f;
17 done
18}
19
20BBCLASSEXTEND = "native nativesdk"