summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dbusmock_0.31.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-dbusmock_0.31.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dbusmock_0.31.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dbusmock_0.31.1.bb b/meta/recipes-devtools/python/python3-dbusmock_0.31.1.bb
new file mode 100644
index 0000000000..fc32c6bbb6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dbusmock_0.31.1.bb
@@ -0,0 +1,22 @@
1SUMMARY = "With this program/Python library you can easily create mock objects on D-Bus"
2HOMEPAGE = "https://pypi.org/project/python-dbusmock/"
3
4LICENSE = "GPL-3.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
6
7SRC_URI[sha256sum] = "b23b8e1b51fe2a9b13e617fff6b60b3ed8e536c080cf3498019d223678d5ea49"
8
9PYPI_PACKAGE = "python-dbusmock"
10
11inherit pypi python_setuptools_build_meta
12DEPENDS += "python3-setuptools-scm-native"
13
14RDEPENDS:${PN} += "\
15 python3-dbus \
16 python3-unittest \
17 python3-xml \
18 "
19
20RRECOMMENDS:${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'gobject-introspection-data', '${MLPREFIX}python3-pygobject', '', d)}"
21
22BBCLASSEXTEND = "native"