summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dbus_1.2.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-dbus_1.2.18.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dbus_1.2.18.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dbus_1.2.18.bb b/meta/recipes-devtools/python/python3-dbus_1.2.18.bb
new file mode 100644
index 0000000000..9592fbf716
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dbus_1.2.18.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4"
6DEPENDS = "expat dbus glib-2.0 virtual/libintl"
7
8SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
9
10SRC_URI[sha256sum] = "92bdd1e68b45596c833307a5ff4b217ee6929a1502f5341bae28fd120acf7260"
11
12S = "${WORKDIR}/dbus-python-${PV}"
13
14inherit distutils3-base autotools pkgconfig
15
16# documentation needs python3-sphinx, which is not in oe-core or meta-python for now
17# change to use PACKAGECONFIG when python3-sphinx is added to oe-core
18EXTRA_OECONF += "--disable-documentation"
19
20
21RDEPENDS:${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
22
23FILES:${PN}-dev += "${libdir}/pkgconfig"
24
25BBCLASSEXTEND = "native nativesdk"