summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb')
-rw-r--r--meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb b/meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb
new file mode 100644
index 0000000000..ee522af08e
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Test vectors for the cryptography package."
2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0 | BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \
6 file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
7 file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b"
8
9# NOTE: Make sure to keep this recipe at the same version as python3-cryptography
10# Upgrade both recipes at the same time
11
12SRC_URI[sha256sum] = "505cd5e3b0cb32da1526f07042b7fc38a4b6c356710cb73d2b5f76b037a38ed1"
13
14PYPI_PACKAGE = "cryptography_vectors"
15
16inherit pypi python_setuptools_build_meta
17
18DEPENDS += " \
19 python3-cryptography \
20"
21
22do_install:append () {
23 # Remove the sha256 checksum lines for pycache files
24 sed ${D}${PYTHON_SITEPACKAGES_DIR}/cryptography_vectors-${PV}.dist-info/RECORD -e '/__pycache__/d' -i
25}
26
27BBCLASSEXTEND = "native nativesdk"
28
29UPSTREAM_CHECK_REGEX = ""
30
31RECIPE_NO_UPDATE_REASON = "Must be updated in sync with python3-cryptography."