summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
new file mode 100644
index 0000000000..93fa645f33
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Modern password hashing for your software and your servers."
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
4HOMEPAGE = "https://pypi.org/project/bcrypt/"
5
6DEPENDS += "python3-cffi-native"
7LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', ' -fuse-ld=bfd', '', d)}"
8
9SRC_URI[sha256sum] = "33313a1200a3ae90b75587ceac502b048b840fc69e7f7a0905b5f87fac7a1258"
10
11inherit pypi python_setuptools3_rust ptest-cargo cargo-update-recipe-crates
12
13SRC_URI += " \
14 file://0001-Bump-pyo3-from-0.20.0-to-0.20.3-in-src-_bcrypt-746.patch \
15 file://run-ptest \
16"
17
18CARGO_SRC_DIR = "src/_bcrypt"
19
20require ${BPN}-crates.inc
21
22RDEPENDS:${PN}-ptest += " \
23 python3-pytest \
24 python3-unittest-automake-output \
25"
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30}
31
32RDEPENDS:${PN}:class-target += "\
33 python3-cffi \
34 python3-ctypes \
35 python3-shell \
36 python3-six \
37"