summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb b/meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb
new file mode 100644
index 0000000000..322497b09b
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb
@@ -0,0 +1,24 @@
1SUMMARY = "A fast, pure Python library for parsing and serializing ASN.1 structures"
2HOMEPAGE = "https://github.com/wbond/asn1crypto"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b5cda97fbd7959ad47a952651a87051a"
6
7PYPI_PACKAGE = "asn1crypto"
8
9SRC_URI[sha256sum] = "13ae38502be632115abf8a24cbe5f4da52e3b5231990aff31123c805306ccb9c"
10
11inherit pypi setuptools3
12
13RDEPENDS:${PN}:class-target += " \
14 python3-codecs \
15 python3-crypt \
16 python3-ctypes \
17 python3-datetime \
18 python3-io \
19 python3-netclient \
20 python3-numbers \
21 python3-shell \
22"
23
24BBCLASSEXTEND = "native nativesdk"