summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-smmap_0.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-smmap_0.8.2.bb')
-rw-r--r--meta/recipes-devtools/python/python-smmap_0.8.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-smmap_0.8.2.bb b/meta/recipes-devtools/python/python-smmap_0.8.2.bb
new file mode 100644
index 0000000000..64f812de00
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smmap_0.8.2.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Python implementation of a sliding window memory map manager"
2DESCRIPTION = "A pure Python implementation of a sliding memory map to \
3help unifying memory mapped access on 32 and 64 bit systems and to help \
4managing resources more efficiently."
5HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
6SECTION = "devel/python"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
9
10SRC_URI = "http://pypi.python.org/packages/source/s/smmap/smmap-${PV}.tar.gz"
11SRC_URI[md5sum] = "f5426b7626ddcf5e447253fae0396b0c"
12SRC_URI[sha256sum] = "dea2955cc045ec5527da6b762f7e95a5be7f645c683b54ccce52d56b4d7e2d6f"
13
14S = "${WORKDIR}/smmap-${PV}"
15
16inherit setuptools
17
18RDEPENDS_${PN} += "python-codecs python-mmap python-lang"
19
20BBCLASSEXTEND = "nativesdk"