summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-smartpm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-smartpm_git.bb')
-rw-r--r--meta/recipes-devtools/python/python-smartpm_git.bb141
1 files changed, 0 insertions, 141 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm_git.bb b/meta/recipes-devtools/python/python-smartpm_git.bb
deleted file mode 100644
index 31c273deaf..0000000000
--- a/meta/recipes-devtools/python/python-smartpm_git.bb
+++ /dev/null
@@ -1,141 +0,0 @@
1SUMMARY = "The Smart Package Manager"
2DESCRIPTION = "The Smart Package Manager project has the ambitious objective of creating \
3smart and portable algorithms for solving adequately the problem of managing software \
4upgrades and installation."
5
6HOMEPAGE = "http://labix.org/smart/"
7SECTION = "devel/python"
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
10
11DEPENDS = "python rpm gettext-native python-rpm"
12SRCNAME = "smart"
13
14SRC_URI = "\
15 git://github.com/smartpm/smart.git \
16 file://smart-recommends.patch \
17 file://smart-channelsdir.patch \
18 file://smart-rpm-transaction-failure-check.patch \
19 file://smart-attempt.patch \
20 file://smart-attempt-fix.patch \
21 file://smart-add-for-rpm-ignoresize-check.patch \
22 file://smart-already-installed-message.patch \
23 file://smart-set-noprogress-for-pycurl.patch \
24 file://smart-cache.py-getPackages-matches-name-version.patch \
25 file://smart-channel-remove-all.patch \
26 file://smart-locale.patch \
27 file://smartpm-rpm5-support-check-signatures.patch \
28 file://smart-add-deugging-when-targetpath-is-empty.patch \
29 file://channels-rpm_sys-use-md5sum-instead-of-mtime-as-the-.patch \
30 "
31
32SRCREV = "407a7eca766431257dcd1da15175cc36a1bb22d0"
33PV = "1.5+git${SRCPV}"
34
35S = "${WORKDIR}/git"
36
37# Options - rpm, qt4, gtk
38PACKAGECONFIG ??= "rpm"
39
40RPM_RDEP = "${PN}-backend-rpm"
41QT_RDEP = "${PN}-interface-qt4"
42GTK_RDEP = "${PN}-interface-gtk"
43
44RPM_RDEP_class-native = ""
45QT_RDEP_class-native = ""
46GTK_RDEP_class-native = ""
47
48RPM_RDEP_class-nativesdk = ""
49QT_RDEP_class-nativesdk = ""
50GTK_RDEP_class-nativesdk = ""
51
52PACKAGECONFIG[rpm] = ",,rpm,${RPM_RDEP}"
53PACKAGECONFIG[qt4] = ",,qt4-x11,${QT_RDEP}"
54PACKAGECONFIG[gtk] = ",,gtk+,${GTK_RDEP}"
55
56inherit distutils
57
58do_install_append() {
59 # We don't support the following items
60 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/backends/slack
61 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/backends/arch
62 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/interfaces/qt
63
64 # Temporary, debian support in OE is missing the python module
65 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/aptchannelsync.py*
66 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/debdir.py*
67 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/backends/deb
68
69 # Disable automatic channel detection
70 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/detectsys.py*
71
72 # Disable landscape support
73 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/landscape.py*
74
75 # Disable urpmi channel support
76 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/urpmichannelsync.py*
77
78 # Disable yum channel support
79 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/yumchannelsync.py*
80
81 # Disable zypper channel support
82 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/zyppchannelsync.py*
83
84 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'rpm', d)}" ]; then
85 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/rpmdir.py*
86 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/backends/rpm
87 fi
88
89 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'qt4', d)}" ]; then
90 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/interfaces/qt4
91 fi
92
93 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'gtk', '', d)}" ]; then
94 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/interfaces/gtk
95 fi
96}
97
98add_native_wrapper() {
99 create_wrapper ${D}/${bindir}/smart \
100 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir'), d.getVar('bindir'))}/rpm \
101 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir'), d.getVar('bindir'))}/rpm} \
102 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}/locale
103}
104
105do_install_append_class-native() {
106 sed -i -e 's|^#!.*/usr/bin/env python|#! /usr/bin/env nativepython|' ${D}${bindir}/smart
107 add_native_wrapper
108}
109
110do_install_append_class-nativesdk() {
111 add_native_wrapper
112}
113
114PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc smartpm \
115 ${@bb.utils.contains('PACKAGECONFIG', 'rpm', '${PN}-backend-rpm', '', d)} \
116 ${@bb.utils.contains('PACKAGECONFIG', 'qt4', '${PN}-interface-qt4', '', d)} \
117 ${@bb.utils.contains('PACKAGECONFIG', 'gtk', '${PN}-interface-gtk', '', d)} \
118 ${PN}-interface-images ${PN}"
119
120RDEPENDS_smartpm = "${PN}"
121
122RDEPENDS_${PN} += "${PN}-backend-rpm python-codecs python-textutils python-xml python-fcntl \
123 python-pickle python-crypt python-compression python-shell \
124 python-resource python-netclient python-threading python-unixadmin python-pprint"
125RDEPENDS_${PN}_class-native = ""
126
127RDEPENDS_${PN}-backend-rpm = "python-rpm"
128
129RDEPENDS_${PN}-interface-qt4 = "qt4-x11 ${PN}-interface-images"
130RDEPENDS_${PN}-interface-gtk = "gtk+ ${PN}-interface-images"
131
132FILES_smartpm = "${bindir}/smart"
133
134FILES_${PN}-backend-rpm = "${PYTHON_SITEPACKAGES_DIR}/smart/backends/rpm"
135
136FILES_${PN}-interface-qt4 = "${PYTHON_SITEPACKAGES_DIR}/smart/interfaces/qt4"
137FILES_${PN}-interface-gtk = "${PYTHON_SITEPACKAGES_DIR}/smart/interfaces/gtk"
138FILES_${PN}-interface-images = "${datadir}/${baselib}/python*/site-packages/smart/interfaces/images"
139
140BBCLASSEXTEND = "native nativesdk"
141