summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_36.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_36.2.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_36.2.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_36.2.0.bb b/meta/recipes-devtools/python/python-setuptools_36.2.0.bb
new file mode 100644
index 0000000000..526474c7ea
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_36.2.0.bb
@@ -0,0 +1,38 @@
1require python-setuptools.inc
2
3PROVIDES = "python-distribute"
4
5DEPENDS += "python"
6DEPENDS_class-native += "python-native"
7
8inherit distutils
9
10DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
11
12RDEPENDS_${PN} = "\
13 python-stringold \
14 python-email \
15 python-shell \
16 python-distutils \
17 python-compression \
18 python-pkgutil \
19 python-plistlib \
20 python-numbers \
21 python-html \
22 python-netserver \
23 python-ctypes \
24 python-subprocess \
25 python-unittest \
26 python-compile \
27"
28
29RDEPENDS_${PN}_class-native = "\
30 python-distutils \
31 python-compression \
32"
33
34RREPLACES_${PN} = "python-distribute"
35RPROVIDES_${PN} = "python-distribute"
36RCONFLICTS_${PN} = "python-distribute"
37
38BBCLASSEXTEND = "native nativesdk"