summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_1.4.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_1.4.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_1.4.bb b/meta/recipes-devtools/python/python-setuptools_1.4.bb
new file mode 100644
index 0000000000..3cfda56ce6
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_1.4.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
3SECTION = "devel/python"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=107;endline=107;md5=8a314270dd7a8dbca741775415f1716e"
6
7SRCNAME = "setuptools"
8DEPENDS += "python"
9DEPENDS_class-native += "python-native"
10
11SRC_URI = "\
12 http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
13"
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit distutils
17
18DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
19
20do_install_prepend() {
21 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
22}
23
24RDEPENDS_${PN} = "\
25 python-stringold \
26 python-email \
27 python-shell \
28 python-distutils \
29 python-compression \
30"
31
32RDEPENDS_${PN}_class-native = "\
33 python-distutils \
34 python-compression \
35"
36
37SRC_URI[md5sum] = "5710464bc5a61d75f5087f15ce63cfe0"
38SRC_URI[sha256sum] = "75d288687066ed124311d6ca5f40ffa92a0e81adcd7fff318c6e84082713cf39"
39
40BBCLASSEXTEND = "native"