summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_0.6c11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_0.6c11.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_0.6c11.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_0.6c11.bb b/meta/recipes-devtools/python/python-setuptools_0.6c11.bb
deleted file mode 100644
index f09a312aec..0000000000
--- a/meta/recipes-devtools/python/python-setuptools_0.6c11.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
3SECTION = "devel/python"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=23;endline=23;md5=8a314270dd7a8dbca741775415f1716e"
6
7SRCNAME = "setuptools"
8PR = "ml5"
9DEPENDS += "python"
10DEPENDS_class-native += "python-native"
11
12SRC_URI = "\
13 http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
14"
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit distutils
18
19DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
20
21do_install_prepend() {
22 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
23}
24
25RDEPENDS_${PN} = "\
26 python-stringold \
27 python-email \
28 python-shell \
29 python-distutils \
30 python-compression \
31"
32
33RDEPENDS_${PN}_class-native = "\
34 python-distutils \
35 python-compression \
36"
37
38SRC_URI[md5sum] = "7df2a529a074f613b509fb44feefe74e"
39SRC_URI[sha256sum] = "630fea9b726320b73ee3ca6ff61732cb32675b0389be658080fe46383b87a1d3"
40
41BBCLASSEXTEND = "native"