summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.3.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.3.bb b/meta/recipes-devtools/python/python-native_2.7.3.bb
index 50bf894d0c..bfdcd12687 100644
--- a/meta/recipes-devtools/python/python-native_2.7.3.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.3.bb
@@ -1,6 +1,6 @@
1require python.inc 1require python.inc
2DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native" 2DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
3PR = "${INC_PR}.0" 3PR = "${INC_PR}.1"
4 4
5SRC_URI += "file://04-default-is-optimized.patch \ 5SRC_URI += "file://04-default-is-optimized.patch \
6 file://05-enable-ctypes-cross-build.patch \ 6 file://05-enable-ctypes-cross-build.patch \
@@ -20,6 +20,8 @@ inherit native
20 20
21RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-core-native" 21RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-core-native"
22 22
23EXTRA_OECONF += " --bindir=${bindir}/${PN}"
24
23EXTRA_OEMAKE = '\ 25EXTRA_OEMAKE = '\
24 BUILD_SYS="" \ 26 BUILD_SYS="" \
25 HOST_SYS="" \ 27 HOST_SYS="" \
@@ -34,11 +36,11 @@ do_configure_prepend() {
34 36
35do_install() { 37do_install() {
36 oe_runmake 'DESTDIR=${D}' install 38 oe_runmake 'DESTDIR=${D}' install
37 install -d ${D}${bindir}/ 39 install -d ${D}${bindir}/${PN}
38 install -m 0755 Parser/pgen ${D}${bindir}/ 40 install -m 0755 Parser/pgen ${D}${bindir}/${PN}
39 41
40 # Make sure we use /usr/bin/env python 42 # Make sure we use /usr/bin/env python
41 for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do 43 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
42 sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT 44 sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
43 done 45 done
44} 46}