summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-gst_0.10.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-gst_0.10.21.bb')
-rw-r--r--meta/recipes-devtools/python/python-gst_0.10.21.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-gst_0.10.21.bb b/meta/recipes-devtools/python/python-gst_0.10.21.bb
new file mode 100644
index 0000000000..dd1ad5f0e8
--- /dev/null
+++ b/meta/recipes-devtools/python/python-gst_0.10.21.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Python Gstreamer bindings"
2SECTION = "devel/python"
3LICENSE = "LGPLv2.1"
4DEPENDS = "gstreamer gst-plugins-base python-pygobject"
5RDEPENDS_${PN} += "python-pygtk"
6PR = "r0"
7
8SRC_URI = "http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
9 file://python-path.patch"
10
11SRC_URI[md5sum] = "31340ae3e877797a10d088a226d74b16"
12SRC_URI[sha256sum] = "d5962132c84b88b54d0f63832b8dfcc383a7805827da5abc2d1d215ba86a6f92"
13S = "${WORKDIR}/gst-python-${PV}"
14
15LIC_FILES_CHKSUM = "file://COPYING;md5=39ff67e932b7bdfa9b78bad67151690b"
16
17inherit autotools distutils-base pkgconfig
18
19EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
20
21FILES_${PN} += "${datadir}/gst-python"
22FILES_${PN}-dev += "${datadir}/gst-python/0.10/defs"
23FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/.debug/"