summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-git_0.3.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-git_0.3.6.bb')
-rw-r--r--meta/recipes-devtools/python/python-git_0.3.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-git_0.3.6.bb b/meta/recipes-devtools/python/python-git_0.3.6.bb
new file mode 100644
index 0000000000..80cdd7cde0
--- /dev/null
+++ b/meta/recipes-devtools/python/python-git_0.3.6.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
10DEPENDS = "python-gitdb"
11
12SRC_URI = "http://pypi.python.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
13
14SRC_URI[md5sum] = "87404ab9e0fcee81e660e932b3d9f2c6"
15SRC_URI[sha256sum] = "f3f42ca085eedbd3a9956b5e639de58bbe77a119f6b3d5c3af27669a2322c4a9"
16
17S = "${WORKDIR}/GitPython-${PV}"
18
19inherit setuptools
20
21RDEPENDS_${PN} += "python-gitdb python-lang python-io python-shell python-math python-re python-subprocess python-stringold"
22
23BBCLASSEXTEND = "nativesdk"