summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-distribute_0.6.32.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-distribute_0.6.32.bb')
-rw-r--r--meta/recipes-devtools/python/python-distribute_0.6.32.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-distribute_0.6.32.bb b/meta/recipes-devtools/python/python-distribute_0.6.32.bb
new file mode 100644
index 0000000000..70001457e0
--- /dev/null
+++ b/meta/recipes-devtools/python/python-distribute_0.6.32.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "http://packages.python.org/distribute"
3SECTION = "devel/python"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=234;endline=234;md5=26f6b02022b737126d3c88838782dddb"
6
7SRCNAME = "distribute"
8PR = "ml5"
9DEPENDS += "python"
10DEPENDS_class-native += "python-native"
11
12SRC_URI = " \
13 http://pypi.python.org/packages/source/d/distribute/${SRCNAME}-${PV}.tar.gz \
14"
15SRC_URI[md5sum] = "acb7a2da81e3612bfb1608abe4f0e568"
16SRC_URI[sha256sum] = "8970cd1e148b5d1fea9430584aea66c45ea22d80e0933393ec49ebc388f718df"
17
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20# http://python-distribute.org/distribute_setup.py
21
22# force the selection of python3
23#PYTHON_BASEVERSION = "3.3"
24#PYTHON_MAJMIN = "3.3"
25
26inherit distutils
27
28DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
29
30do_install_prepend() {
31 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
32}
33
34#
35# The installer puts the wrong path in the setuptools.pth file. Correct it.
36#
37do_install_append() {
38 rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
39 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
40}
41
42do_install_append_class-nativesdk() {
43 sed -i -e '1s|^#!.*|#!/usr/bin/env python|' ${D}${PYTHON_SITEPACKAGES_DIR}/distribute-${PV}-py${PYTHON_BASEVERSION}.egg/setuptools/tests/test_resources.py
44 sed -i -e '1s|^#!.*|#!/usr/bin/env python|' ${D}${bindir}/easy_install
45 sed -i -e '1s|^#!.*|#!/usr/bin/env python|' ${D}${bindir}/easy_install-${PYTHON_BASEVERSION}
46}
47
48RDEPENDS_${PN} = "\
49 python-distutils \
50 python-compression \
51"
52
53RPROVIDES_${PN} += "python-setuptools"
54
55BBCLASSEXTEND = "native nativesdk"