summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-dbus_1.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-dbus_1.2.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-dbus_1.2.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-dbus_1.2.0.bb b/meta/recipes-devtools/python/python-dbus_1.2.0.bb
new file mode 100644
index 0000000000..a185d841e2
--- /dev/null
+++ b/meta/recipes-devtools/python/python-dbus_1.2.0.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0b83047ce9e948b67c0facc5f233476a"
6DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
7
8SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
9"
10
11SRC_URI[md5sum] = "b09cd2d1a057cc432ce944de3fc06bf7"
12SRC_URI[sha256sum] = "e12c6c8b2bf3a9302f75166952cbe41d6b38c3441bbc6767dbd498942316c6df"
13S = "${WORKDIR}/dbus-python-${PV}"
14
15inherit distutils-base autotools pkgconfig
16
17export BUILD_SYS
18export HOST_SYS
19
20export STAGING_LIBDIR
21export STAGING_INCDIR
22
23RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
24
25FILES_${PN}-dev += "${libdir}/pkgconfig"