summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb')
-rw-r--r--meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb b/meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb
new file mode 100644
index 0000000000..8d348d85ca
--- /dev/null
+++ b/meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb
@@ -0,0 +1,56 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & BSD & MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=474c7e8e97b80fb7500de2b0c4a4a8d4"
5
6SRCNAME = "numpy"
7
8SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
9 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
10 file://0001-numpy-core-Define-RISCV-32-support.patch \
11 file://run-ptest \
12"
13SRC_URI[sha256sum] = "67b630745a71b541ff6517d6f3d62b00690dc8ba0684cad0d7b0ac55aec1de53"
14
15UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
16UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
17
18DEPENDS += "python3-cython-native"
19
20inherit ptest setuptools3
21
22S = "${WORKDIR}/numpy-${PV}"
23
24CLEANBROKEN = "1"
25
26FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
27
28# install what is needed for numpy.test()
29RDEPENDS_${PN} = "${PYTHON_PN}-unittest \
30 ${PYTHON_PN}-difflib \
31 ${PYTHON_PN}-pprint \
32 ${PYTHON_PN}-pickle \
33 ${PYTHON_PN}-shell \
34 ${PYTHON_PN}-doctest \
35 ${PYTHON_PN}-datetime \
36 ${PYTHON_PN}-distutils \
37 ${PYTHON_PN}-misc \
38 ${PYTHON_PN}-mmap \
39 ${PYTHON_PN}-netclient \
40 ${PYTHON_PN}-numbers \
41 ${PYTHON_PN}-pydoc \
42 ${PYTHON_PN}-pkgutil \
43 ${PYTHON_PN}-email \
44 ${PYTHON_PN}-compression \
45 ${PYTHON_PN}-ctypes \
46 ${PYTHON_PN}-threading \
47 ${PYTHON_PN}-multiprocessing \
48"
49RDEPENDS_${PN}-ptest += "${PYTHON_PN}-pytest \
50 ${PYTHON_PN}-hypothesis \
51 ${PYTHON_PN}-sortedcontainers \
52 ${PYTHON_PN}-resource \
53 ldd \
54"
55
56BBCLASSEXTEND = "native nativesdk"