summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.30.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.30.1.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.30.1.bb336
1 files changed, 336 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.30.1.bb b/meta/recipes-devtools/perl/perl_5.30.1.bb
new file mode 100644
index 0000000000..9b1f1af072
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl_5.30.1.bb
@@ -0,0 +1,336 @@
1SUMMARY = "Perl scripting language"
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "devel"
4LICENSE = "Artistic-1.0 | GPL-1.0+"
5LIC_FILES_CHKSUM = "file://Copying;md5=5b122a36d0f6dc55279a0ebc69f3c60b \
6 file://Artistic;md5=71a4d5d9acc18c0952a6df2218bb68da \
7 "
8
9
10SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
11 https://github.com/arsv/perl-cross/releases/download/1.3.1/perl-cross-1.3.1.tar.gz;name=perl-cross \
12 file://perl-rdepends.txt \
13 file://0001-configure_tool.sh-do-not-quote-the-argument-to-comma.patch \
14 file://0001-ExtUtils-MakeMaker-add-LDFLAGS-when-linking-binary-m.patch \
15 file://0001-Somehow-this-module-breaks-through-the-perl-wrapper-.patch \
16 file://errno_ver.diff \
17 file://native-perlinc.patch \
18 file://0001-perl-cross-add-LDFLAGS-when-linking-libperl.patch \
19 file://perl-dynloader.patch \
20 file://0001-configure_path.sh-do-not-hardcode-prefix-lib-as-libr.patch \
21 file://0001-enc2xs-Add-environment-variable-to-suppress-comments.patch \
22 file://0002-Constant-Fix-up-shebang.patch \
23 "
24SRC_URI_append_class-native = " \
25 file://perl-configpm-switch.patch \
26"
27
28SRC_URI[perl.md5sum] = "6438eb7b8db9bbde28e01086de376a46"
29SRC_URI[perl.sha256sum] = "bf3d25571ff1ee94186177c2cdef87867fd6a14aa5a84f0b1fb7bf798f42f964"
30SRC_URI[perl-cross.md5sum] = "1e463b105cfa56d251a86979af23e3a7"
31SRC_URI[perl-cross.sha256sum] = "edce0b0c2f725e2db3f203d6d8e9f3f7161256f5d1590551e40694f21200141d"
32
33S = "${WORKDIR}/perl-${PV}"
34
35inherit upstream-version-is-even
36
37DEPENDS += "zlib virtual/crypt"
38
39PERL_LIB_VER = "${@'.'.join(d.getVar('PV').split('.')[0:2])}.0"
40
41PACKAGECONFIG ??= "bdb gdbm"
42PACKAGECONFIG[bdb] = ",-Ui_db,db"
43PACKAGECONFIG[gdbm] = ",-Ui_gdbm,gdbm"
44
45# Don't generate comments in enc2xs output files. They are not reproducible
46export ENC2XS_NO_COMMENTS = "1"
47
48do_unpack_append() {
49 bb.build.exec_func('do_copy_perlcross', d)
50}
51
52do_copy_perlcross() {
53 cp -rfp ${WORKDIR}/perl-cross*/* ${S}
54}
55
56do_configure_class-target() {
57 ./configure --prefix=${prefix} --libdir=${libdir} \
58 --target=${TARGET_SYS} \
59 -Duseshrplib \
60 -Dsoname=libperl.so.5 \
61 -Dvendorprefix=${prefix} \
62 -Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux \
63 ${PACKAGECONFIG_CONFARGS}
64
65 #perl.c uses an ARCHLIB_EXP define to generate compile-time code that
66 #adds the archlibexp path to @INC during run-time initialization of a
67 #new perl interpreter.
68
69 #Because we've changed this value in a temporary way to make it
70 #possible to use ExtUtils::Embed in the target build (the temporary
71 #value in config.sh gets re-stripped out during packaging), the
72 #ARCHLIB_EXP value that gets generated still uses the temporary version
73 #instead of the original expected version (i.e. becauses it's in the
74 #generated config.h, it doesn't get stripped out during packaging like
75 #the others in config.sh).
76
77 sed -i -e "s,${STAGING_LIBDIR},${libdir},g" config.h
78}
79
80do_configure_class-nativesdk() {
81 ./configure --prefix=${prefix} \
82 --target=${TARGET_SYS} \
83 -Duseshrplib \
84 -Dsoname=libperl.so.5 \
85 -Dvendorprefix=${prefix} \
86 -Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux \
87 ${PACKAGECONFIG_CONFARGS}
88
89 # See the comment above
90 sed -i -e "s,${STAGING_LIBDIR},${libdir},g" config.h
91}
92
93do_configure_class-native() {
94 ./configure --prefix=${prefix} \
95 -Dbin=${bindir}/perl-native \
96 -Duseshrplib \
97 -Dsoname=libperl.so.5 \
98 -Dvendorprefix=${prefix} \
99 -Ui_xlocale \
100 ${PACKAGECONFIG_CONFARGS}
101}
102
103do_configure_append() {
104 if [ -n "$SOURCE_DATE_EPOCH" ]; then
105 PERL_BUILD_DATE="$(${PYTHON} -c "\
106from datetime import datetime, timezone; \
107print(datetime.fromtimestamp($SOURCE_DATE_EPOCH, timezone.utc).strftime('%a %b %d %H:%M:%S %Y')) \
108 ")"
109 echo "#define PERL_BUILD_DATE \"$PERL_BUILD_DATE\"" >> config.h
110 fi
111}
112
113do_compile() {
114 oe_runmake
115}
116
117do_install() {
118 oe_runmake 'DESTDIR=${D}' install
119
120 install -d ${D}${libdir}/perl5
121 install -d ${D}${libdir}/perl5/${PV}/
122 install -d ${D}${libdir}/perl5/${PV}/ExtUtils/
123
124 # Save native config
125 install config.sh ${D}${libdir}/perl5
126 install lib/Config.pm ${D}${libdir}/perl5/${PV}/
127 install lib/ExtUtils/typemap ${D}${libdir}/perl5/${PV}/ExtUtils/
128
129 # Fix up shared library
130 rm ${D}/${libdir}/perl5/${PV}/*/CORE/libperl.so
131 ln -sf ../../../../libperl.so.${PERL_LIB_VER} $(echo ${D}/${libdir}/perl5/${PV}/*/CORE)/libperl.so
132}
133
134do_install_append_class-target() {
135 # This is used to substitute target configuration when running native perl via perl-configpm-switch.patch
136 ln -s Config_heavy.pl ${D}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_heavy-target.pl
137
138}
139
140do_install_append_class-nativesdk() {
141 # This is used to substitute target configuration when running native perl via perl-configpm-switch.patch
142 ln -s Config_heavy.pl ${D}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_heavy-target.pl
143
144 create_wrapper ${D}${bindir}/perl \
145 PERL5LIB='$PERL5LIB:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl5/site_perl/${PV}:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl5/vendor_perl/${PV}:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl5/${PV}'
146}
147
148do_install_append_class-native () {
149 # Those wrappers mean that perl installed from sstate (which may change
150 # path location) works and that in the nativesdk case, the SDK can be
151 # installed to a different location from the one it was built for.
152 create_wrapper ${D}${bindir}/perl-native/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl5/site_perl/${PV}:${STAGING_LIBDIR}/perl5/vendor_perl/${PV}:${STAGING_LIBDIR}/perl5/${PV}'
153
154 # Use /usr/bin/env nativeperl for the perl script.
155 for f in `grep -Il '#! *${bindir}/perl' ${D}/${bindir}/*`; do
156 sed -i -e 's|${bindir}/perl|/usr/bin/env nativeperl|' $f
157 done
158}
159
160PACKAGE_PREPROCESS_FUNCS += "perl_package_preprocess"
161
162perl_package_preprocess () {
163 # Fix up installed configuration
164 sed -i -e "s,${D},,g" \
165 -e "s,${DEBUG_PREFIX_MAP},,g" \
166 -e "s,--sysroot=${STAGING_DIR_HOST},,g" \
167 -e "s,-isystem${STAGING_INCDIR} ,,g" \
168 -e "s,${STAGING_LIBDIR},${libdir},g" \
169 -e "s,${STAGING_BINDIR},${bindir},g" \
170 -e "s,${STAGING_INCDIR},${includedir},g" \
171 -e "s,${STAGING_BINDIR_NATIVE}/perl-native/,${bindir}/,g" \
172 -e "s,${STAGING_BINDIR_NATIVE}/,,g" \
173 -e "s,${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX},${bindir},g" \
174 -e 's:${RECIPE_SYSROOT}::g' \
175 ${PKGD}${bindir}/h2xs \
176 ${PKGD}${bindir}/h2ph \
177 ${PKGD}${bindir}/pod2man \
178 ${PKGD}${bindir}/pod2text \
179 ${PKGD}${bindir}/pod2usage \
180 ${PKGD}${bindir}/podchecker \
181 ${PKGD}${bindir}/podselect \
182 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/config.h \
183 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/perl.h \
184 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/pp.h \
185 ${PKGD}${libdir}/perl5/${PV}/Config.pm \
186 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config.pm \
187 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config.pod \
188 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_git.pl \
189 ${PKGD}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_heavy.pl \
190 ${PKGD}${libdir}/perl5/${PV}/ExtUtils/Liblist/Kid.pm \
191 ${PKGD}${libdir}/perl5/${PV}/FileCache.pm \
192 ${PKGD}${libdir}/perl5/${PV}/pod/*.pod \
193 ${PKGD}${libdir}/perl5/config.sh
194}
195
196require perl-ptest.inc
197
198FILES_${PN} = "${bindir}/perl ${bindir}/perl.real ${bindir}/perl${PV} ${libdir}/libperl.so* \
199 ${libdir}/perl5/site_perl \
200 ${libdir}/perl5/${PV}/Config.pm \
201 ${libdir}/perl5/${PV}/*/Config_git.pl \
202 ${libdir}/perl5/${PV}/*/Config_heavy-target.pl \
203 ${libdir}/perl5/config.sh \
204 ${libdir}/perl5/${PV}/strict.pm \
205 ${libdir}/perl5/${PV}/warnings.pm \
206 ${libdir}/perl5/${PV}/warnings \
207 ${libdir}/perl5/${PV}/vars.pm \
208 ${libdir}/perl5/site_perl \
209 "
210RPROVIDES_${PN} += "perl-module-strict perl-module-vars perl-module-config perl-module-warnings \
211 perl-module-warnings-register"
212
213FILES_${PN}-staticdev_append = " ${libdir}/perl5/${PV}/*/CORE/libperl.a"
214
215FILES_${PN}-dev_append = " ${libdir}/perl5/${PV}/*/CORE"
216
217FILES_${PN}-doc_append = " ${libdir}/perl5/${PV}/Unicode/Collate/*.txt \
218 ${libdir}/perl5/${PV}/*/.packlist \
219 ${libdir}/perl5/${PV}/ExtUtils/MANIFEST.SKIP \
220 ${libdir}/perl5/${PV}/ExtUtils/xsubpp \
221 ${libdir}/perl5/${PV}/ExtUtils/typemap \
222 ${libdir}/perl5/${PV}/Encode/encode.h \
223 "
224PACKAGES += "${PN}-misc"
225
226FILES_${PN}-misc = "${bindir}/*"
227
228PACKAGES += "${PN}-pod"
229
230FILES_${PN}-pod = "${libdir}/perl5/${PV}/pod \
231 ${libdir}/perl5/${PV}/*.pod \
232 ${libdir}/perl5/${PV}/*/*.pod \
233 ${libdir}/perl5/${PV}/*/*/*.pod \
234 ${libdir}/perl5/${PV}/*/*/*/*.pod \
235 "
236
237PACKAGES += "${PN}-module-cpan ${PN}-module-unicore"
238
239FILES_${PN}-module-cpan += "${libdir}/perl5/${PV}/CPAN \
240 "
241FILES_${PN}-module-unicore += "${libdir}/perl5/${PV}/unicore"
242
243# Create a perl-modules package recommending all the other perl
244# packages (actually the non modules packages and not created too)
245ALLOW_EMPTY_${PN}-modules = "1"
246PACKAGES += "${PN}-modules "
247
248PACKAGESPLITFUNCS_prepend = "split_perl_packages "
249
250python split_perl_packages () {
251 libdir = d.expand('${libdir}/perl5/${PV}')
252 do_split_packages(d, libdir, r'.*/auto/([^.]*)/[^/]*\.(so|ld|ix|al)', '${PN}-module-%s', 'perl module %s', recursive=True, match_path=True, prepend=False)
253 do_split_packages(d, libdir, r'.*linux/([^\/]*)\.pm', '${PN}-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
254 do_split_packages(d, libdir, r'Module/([^\/]*)\.pm', '${PN}-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
255 do_split_packages(d, libdir, r'Module/([^\/]*)/.*', '${PN}-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
256 do_split_packages(d, libdir, r'.*linux/([^\/].*)\.(pm|pl|e2x)', '${PN}-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
257 do_split_packages(d, libdir, r'(^(?!(CPAN\/|CPANPLUS\/|Module\/|unicore\/)[^\/]).*)\.(pm|pl|e2x)', '${PN}-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
258
259 # perl-modules should recommend every perl module, and only the
260 # modules. Don't attempt to use the result of do_split_packages() as some
261 # modules are manually split (eg. perl-module-unicore).
262 packages = filter(lambda p: 'perl-module-' in p, d.getVar('PACKAGES').split())
263 d.setVar(d.expand("RRECOMMENDS_${PN}-modules"), ' '.join(packages))
264
265 # Read the pre-generated dependency file, and use it to set module dependecies
266 for line in open(d.expand("${WORKDIR}") + '/perl-rdepends.txt').readlines():
267 splitline = line.split()
268 if bb.data.inherits_class('native', d):
269 module = splitline[0] + '-native'
270 depends = "perl-native"
271 else:
272 module = splitline[0].replace("RDEPENDS_perl", "RDEPENDS_${PN}")
273 depends = splitline[2].strip('"').replace("perl-module", "${PN}-module")
274 d.appendVar(d.expand(module), " " + depends)
275}
276
277python() {
278 if d.getVar('CLASSOVERRIDE') == "class-target":
279 d.setVar("PACKAGES_DYNAMIC", "^perl-module-.*(?<!native)$")
280 elif d.getVar('CLASSOVERRIDE') == "class-native":
281 d.setVar("PACKAGES_DYNAMIC", "^perl-module-.*-native$")
282 elif d.getVar('CLASSOVERRIDE') == "class-nativesdk":
283 d.setVar("PACKAGES_DYNAMIC", "^nativesdk-perl-module-.*")
284}
285
286RDEPENDS_${PN}-misc += "perl perl-modules"
287RDEPENDS_${PN}-pod += "perl"
288
289BBCLASSEXTEND = "native nativesdk"
290
291SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"
292
293do_create_rdepends_inc() {
294 cd ${WORKDIR}
295 cat <<'EOPREAMBLE' > ${WORKDIR}/perl-rdepends.inc
296
297# Some additional dependencies that the above doesn't manage to figure out
298RDEPENDS_${PN}-module-file-spec += "${PN}-module-file-spec-unix"
299RDEPENDS_${PN}-module-math-bigint += "${PN}-module-math-bigint-calc"
300RDEPENDS_${PN}-module-thread-queue += "${PN}-module-attributes"
301RDEPENDS_${PN}-module-overload += "${PN}-module-overloading"
302
303# Generated depends list beyond this line
304EOPREAMBLE
305 test -e packages-split.new && rm -rf packages-split.new
306 cp -r packages-split packages-split.new && cd packages-split.new
307 find . -name \*.pm | xargs sed -i '/^=head/,/^=cut/d'
308 egrep -r "^\s*(\<use .*|\<require .*);?" perl-module-* --include="*.pm" | \
309 sed "s/\/.*\.pm: */ += /g;s/[\"\']//g;s/;.*/\"/g;s/+= .*\(require\|use\)\> */+= \"perl-module-/g;s/CPANPLUS::.*/cpanplus/g;s/CPAN::.*/cpan/g;s/::/-/g;s/ [^+\"].*//g;s/_/-/g;s/\.pl\"$/\"/;s/\"\?\$/\"/;s/(//;" | tr [:upper:] [:lower:] | \
310 awk '{if ($3 != "\x22"$1"\x22"){ print $0}}'| \
311 grep -v -e "\-vms\-" -e module-5 -e "^$" -e "\\$" -e your -e tk -e autoperl -e html -e http -e parse-cpan -e perl-ostype -e ndbm-file -e module-mac -e fcgi -e lwp -e dbd -e dbix | \
312 sort -u | \
313 sed 's/^/RDEPENDS_/;s/perl-module-/${PN}-module-/g;s/module-\(module-\)/\1/g;s/\(module-load\)-conditional/\1/g;s/encode-configlocal/&-pm/;' | \
314 egrep -wv '=>|module-a|module-apache.?|module-apr|module-authen-sasl|module-b-asmdata|module-convert-ebcdic|module-devel-size|module-digest-perl-md5|module-dumpvalue|module-extutils-constant-aaargh56hash|module-extutils-xssymset|module-file-bsdglob|module-for|module-it|module-io-socket-inet6|module-io-socket-ssl|module-io-string|module-ipc-system-simple|module-lexical|module-local-lib|metadata|module-modperl-util|module-pluggable-object|module-test-builder-io-scalar|module-test2|module-text-unidecode|module-unicore|module-win32|objects\sload|syscall.ph|systeminfo.ph|%s' | \
315 egrep -wv '=>|module-algorithm-diff|module-carp|module-c<extutils-mm-unix>|module-encode-hanextra|module-extutils-makemaker-version-regex|module-file-spec|module-io-compress-lzma|module-locale-maketext-lexicon|module-log-agent|module-meta-notation|module-net-localcfg|module-net-ping-external|module-b-deparse|module-scalar-util|module-some-module|module-symbol|module-uri|module-win32api-file' >> ${WORKDIR}/perl-rdepends.generated
316 cp ${WORKDIR}/perl-rdepends.generated ${THISDIR}/files/perl-rdepends.txt
317}
318
319# bitbake perl -c create_rdepends_inc
320addtask do_create_rdepends_inc
321
322SYSROOT_PREPROCESS_FUNCS += "perl_sysroot_create_wrapper"
323
324perl_sysroot_create_wrapper () {
325 mkdir -p ${SYSROOT_DESTDIR}${bindir}
326 # Create a wrapper that /usr/bin/env perl will use to get perl-native.
327 # This MUST live in the normal bindir.
328 cat > ${SYSROOT_DESTDIR}${bindir}/nativeperl << EOF
329#!/bin/sh
330realpath=\`readlink -fn \$0\`
331exec \`dirname \$realpath\`/perl-native/perl "\$@"
332EOF
333 chmod 0755 ${SYSROOT_DESTDIR}${bindir}/nativeperl
334 cat ${SYSROOT_DESTDIR}${bindir}/nativeperl
335}
336