summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.24.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.24.1.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.24.1.bb13
1 files changed, 0 insertions, 13 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.24.1.bb b/meta/recipes-devtools/perl/perl_5.24.1.bb
index 147e151d74..cf7a8e1218 100644
--- a/meta/recipes-devtools/perl/perl_5.24.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.24.1.bb
@@ -99,17 +99,6 @@ LDFLAGS_append = " -fstack-protector"
99# We're almost Debian, aren't we? 99# We're almost Debian, aren't we?
100CFLAGS += "-DDEBIAN" 100CFLAGS += "-DDEBIAN"
101 101
102do_nolargefile() {
103 sed -i -e "s,\(uselargefiles=\)'define',\1'undef',g" \
104 -e "s,\(d_readdir64_r=\)'define',\1'undef',g" \
105 -e "s,\(readdir64_r_proto=\)'\w+',\1'0',g" \
106 -e "/ccflags_uselargefiles/d" \
107 -e "s/-Duselargefiles//" \
108 -e "s/-D_FILE_OFFSET_BITS=64//" \
109 -e "s/-D_LARGEFILE_SOURCE//" \
110 ${S}/Cross/config.sh-${TARGET_ARCH}-${TARGET_OS}
111}
112
113do_configure() { 102do_configure() {
114 # Make hostperl in build directory be the native perl 103 # Make hostperl in build directory be the native perl
115 ln -sf ${HOSTPERL} hostperl 104 ln -sf ${HOSTPERL} hostperl
@@ -182,8 +171,6 @@ do_configure() {
182 config.sh-${TARGET_ARCH}-${TARGET_OS} 171 config.sh-${TARGET_ARCH}-${TARGET_OS}
183 fi 172 fi
184 173
185 ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)}
186
187 # Update some paths in the configuration 174 # Update some paths in the configuration
188 sed -i -e 's,@ARCH@-thread-multi,,g' \ 175 sed -i -e 's,@ARCH@-thread-multi,,g' \
189 -e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \ 176 -e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \