summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.20.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.20.0.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.20.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.20.0.bb b/meta/recipes-devtools/perl/perl_5.20.0.bb
index db65202ec8..d100ff9b82 100644
--- a/meta/recipes-devtools/perl/perl_5.20.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.20.0.bb
@@ -165,6 +165,29 @@ do_configure() {
165 -e "s,-fstack-protector,-fno-stack-protector,g" \ 165 -e "s,-fstack-protector,-fno-stack-protector,g" \
166 config.sh-${TARGET_ARCH}-${TARGET_OS} 166 config.sh-${TARGET_ARCH}-${TARGET_OS}
167 fi 167 fi
168 # Fixups for musl
169 if [ "${TARGET_OS}" = "linux-musl" -o "${TARGET_OS}" = "linux-musleabi" ]; then
170 sed -i -e "s,\(d_libm_lib_version=\)'define',\1'undef',g" \
171 -e "s,\(d_stdio_ptr_lval=\)'define',\1'undef',g" \
172 -e "s,\(d_stdio_ptr_lval_sets_cnt=\)'define',\1'undef',g" \
173 -e "s,\(d_stdiobase=\)'define',\1'undef',g" \
174 -e "s,\(d_stdstdio=\)'define',\1'undef',g" \
175 -e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \
176 -e "s,\(getprotobyname_r=\)'define',\1'undef',g" \
177 -e "s,\(getpwent_r=\)'define',\1'undef',g" \
178 -e "s,\(getservent_r=\)'define',\1'undef',g" \
179 -e "s,\(gethostent_r=\)'define',\1'undef',g" \
180 -e "s,\(getnetent_r=\)'define',\1'undef',g" \
181 -e "s,\(getnetbyaddr_r=\)'define',\1'undef',g" \
182 -e "s,\(getprotoent_r=\)'define',\1'undef',g" \
183 -e "s,\(getprotobynumber_r=\)'define',\1'undef',g" \
184 -e "s,\(getgrent_r=\)'define',\1'undef',g" \
185 -e "s,\(i_fcntl=\)'undef',\1'define',g" \
186 -e "s,\(h_fcntl=\)'false',\1'true',g" \
187 -e "s,-fstack-protector,-fno-stack-protector,g" \
188 -e "s,-lnsl,,g" \
189 config.sh-${TARGET_ARCH}-${TARGET_OS}
190 fi
168 191
169 ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)} 192 ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)}
170 193