summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-native_5.20.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.20.0.bb')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.20.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.20.0.bb b/meta/recipes-devtools/perl/perl-native_5.20.0.bb
index 4364d41b35..069696ae0c 100644
--- a/meta/recipes-devtools/perl/perl-native_5.20.0.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.20.0.bb
@@ -105,6 +105,11 @@ do_install () {
105 105
106 create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/' 106 create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
107 create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/' 107 create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
108
109 # Use /usr/bin/env nativeperl for the perl script.
110 for f in `grep -Il '#! *${bindir}/perl' ${D}/${bindir}/*`; do
111 sed -i -e 's|${bindir}/perl|/usr/bin/env nativeperl|' $f
112 done
108} 113}
109 114
110SYSROOT_PREPROCESS_FUNCS += "perl_sysroot_create_wrapper" 115SYSROOT_PREPROCESS_FUNCS += "perl_sysroot_create_wrapper"