summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-native_5.14.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.14.3.bb')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.14.3.bb123
1 files changed, 123 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.14.3.bb b/meta/recipes-devtools/perl/perl-native_5.14.3.bb
new file mode 100644
index 0000000000..2ef0a5135c
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl-native_5.14.3.bb
@@ -0,0 +1,123 @@
1SUMMARY = "Perl scripting language"
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "libs"
4LICENSE = "Artistic-1.0 | GPL-1.0"
5
6LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
7 file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
8
9# 5.10.1 has Module::Build built-in
10PROVIDES += "libmodule-build-perl-native"
11
12SRC_URI = "http://www.cpan.org/src/5.0/perl-${PV}.tar.gz \
13 file://Configure-multilib.patch \
14 file://perl-configpm-switch.patch \
15 file://native-nopacklist.patch \
16 file://native-perlinc.patch \
17 file://MM_Unix.pm.patch \
18 file://debian/errno_ver.diff \
19 file://dynaloaderhack.patch \
20 file://perl-build-in-t-dir.patch"
21
22SRC_URI[md5sum] = "f6a3d878c688d111b495c87db56c5be5"
23SRC_URI[sha256sum] = "03638a4f01bc26b81231233671524b4163849a3a9ea5cc2397293080c4ea339f"
24
25S = "${WORKDIR}/perl-${PV}"
26
27inherit native
28
29NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
30
31export LD="${CCLD}"
32
33do_configure () {
34 ./Configure \
35 -Dcc="${CC}" \
36 -Dcflags="${CFLAGS}" \
37 -Dldflags="${LDFLAGS}" \
38 -Dcf_by="Open Embedded" \
39 -Dprefix=${prefix} \
40 -Dvendorprefix=${prefix} \
41 -Dvendorprefix=${prefix} \
42 -Dsiteprefix=${prefix} \
43 \
44 -Dbin=${STAGING_BINDIR}/${PN} \
45 -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
46 -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
47 -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \
48 -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \
49 -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \
50 -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \
51 \
52 -Duseshrplib \
53 -Dusethreads \
54 -Duseithreads \
55 -Duselargefiles \
56 -Dnoextensions=ODBM_File \
57 -Ud_dosuid \
58 -Ui_db \
59 -Ui_ndbm \
60 -Ui_gdbm \
61 -Di_shadow \
62 -Di_syslog \
63 -Duseperlio \
64 -Dman3ext=3pm \
65 -Dsed=/bin/sed \
66 -Uafs \
67 -Ud_csh \
68 -Uusesfio \
69 -Uusenm -des
70}
71
72do_install () {
73 oe_runmake 'DESTDIR=${D}' install
74
75 # We need a hostperl link for building perl
76 ln -sf perl${PV} ${D}${bindir}/hostperl
77
78 ln -sf perl ${D}${libdir}/perl5
79
80 install -d ${D}${libdir}/perl/${PV}/CORE \
81 ${D}${datadir}/perl/${PV}/ExtUtils
82
83 # Save native config
84 install config.sh ${D}${libdir}/perl
85 install lib/Config.pm ${D}${libdir}/perl/${PV}/
86 install lib/ExtUtils/typemap ${D}${libdir}/perl/${PV}/ExtUtils/
87
88 # perl shared library headers
89 for i in av.h bitcount.h config.h cop.h cv.h dosish.h embed.h embedvar.h \
90 EXTERN.h fakesdio.h fakethr.h form.h gv.h handy.h hv.h INTERN.h \
91 intrpvar.h iperlsys.h keywords.h l1_char_class_tab.h malloc_ctl.h \
92 metaconfig.h mg.h mydtrace.h nostdio.h opcode.h op.h opnames.h \
93 op_reg_common.h overload.h pad.h parser.h patchlevel.h perlapi.h \
94 perl.h perlio.h perliol.h perlsdio.h perlsfio.h perlvars.h \
95 perly.h pp.h pp_proto.h proto.h reentr.h regcharclass.h regcomp.h \
96 regexp.h regnodes.h scope.h sv.h thread.h time64_config.h \
97 time64.h uconfig.h unixish.h utf8.h utfebcdic.h util.h \
98 uudmap.h warnings.h XSUB.h
99 do
100 install $i ${D}${libdir}/perl/${PV}/CORE
101 done
102
103 create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
104 create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
105}
106
107SYSROOT_PREPROCESS_FUNCS += "perl_sysroot_create_wrapper"
108
109perl_sysroot_create_wrapper () {
110 mkdir -p ${SYSROOT_DESTDIR}${bindir}
111 # Create a wrapper that /usr/bin/env perl will use to get perl-native.
112 # This MUST live in the normal bindir.
113 cat > ${SYSROOT_DESTDIR}${bindir}/../nativeperl << EOF
114#!/bin/sh
115realpath=\`readlink -fn \$0\`
116exec \`dirname \$realpath\`/perl-native/perl "\$@"
117EOF
118 chmod 0755 ${SYSROOT_DESTDIR}${bindir}/../nativeperl
119 cat ${SYSROOT_DESTDIR}${bindir}/../nativeperl
120}
121
122# Fix the path in sstate
123SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"