summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-5.14.3/debian/db_file_ver.diff
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl-5.14.3/debian/db_file_ver.diff')
-rw-r--r--meta/recipes-devtools/perl/perl-5.14.3/debian/db_file_ver.diff35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-5.14.3/debian/db_file_ver.diff b/meta/recipes-devtools/perl/perl-5.14.3/debian/db_file_ver.diff
new file mode 100644
index 0000000..8726056
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl-5.14.3/debian/db_file_ver.diff
@@ -0,0 +1,35 @@
1Upstream-Status:Inappropriate [debian patches]
2From 0d1acf7af6da3a3f933faba8459ad9ff03fe3e5b Mon Sep 17 00:00:00 2001
3From: Brendan O'Dea <bod@debian.org>
4Date: Fri, 16 Dec 2005 01:32:14 +1100
5Subject: Remove overly restrictive DB_File version check.
6
7Bug-Debian: http://bugs.debian.org/340047
8
9Package dependencies ensure the correct library is linked at run-time.
10
11Patch-Name: debian/db_file_ver.diff
12---
13 cpan/DB_File/version.c | 2 ++
14 1 files changed, 2 insertions(+), 0 deletions(-)
15
16diff --git a/cpan/DB_File/version.c b/cpan/DB_File/version.c
17index e01f6f6..544e6ee 100644
18--- a/cpan/DB_File/version.c
19+++ b/cpan/DB_File/version.c
20@@ -48,6 +48,7 @@ __getBerkeleyDBInfo()
21
22 (void)db_version(&Major, &Minor, &Patch) ;
23
24+#ifndef DEBIAN
25 /* Check that the versions of db.h and libdb.a are the same */
26 if (Major != DB_VERSION_MAJOR || Minor != DB_VERSION_MINOR )
27 /* || Patch != DB_VERSION_PATCH) */
28@@ -55,6 +56,7 @@ __getBerkeleyDBInfo()
29 croak("\nDB_File was build with libdb version %d.%d.%d,\nbut you are attempting to run it with libdb version %d.%d.%d\n",
30 DB_VERSION_MAJOR, DB_VERSION_MINOR, DB_VERSION_PATCH,
31 Major, Minor, Patch) ;
32+#endif /* DEBIAN */
33
34 /* check that libdb is recent enough -- we need 2.3.4 or greater */
35 if (Major == 2 && (Minor < 3 || (Minor == 3 && Patch < 4)))