summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libxml-simple-perl_2.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/libxml-simple-perl_2.22.bb')
-rw-r--r--meta/recipes-devtools/perl/libxml-simple-perl_2.22.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libxml-simple-perl_2.22.bb b/meta/recipes-devtools/perl/libxml-simple-perl_2.22.bb
new file mode 100644
index 0000000000..2243bb2c26
--- /dev/null
+++ b/meta/recipes-devtools/perl/libxml-simple-perl_2.22.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Perl module for reading and writing XML"
2DESCRIPTION = "The XML::Simple Perl module provides a simple API layer \
3on top of an underlying XML parsing module to maintain XML files \
4(especially configuration files). It is a blunt rewrite of XML::Simple \
5(by Grant McLean) to use the XML::LibXML parser for XML structures, \
6where the original uses plain Perl or SAX parsers."
7HOMEPAGE = "http://search.cpan.org/~markov/XML-LibXML-Simple-0.93/lib/XML/LibXML/Simple.pod"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=fa1187fceda00eee10b62961407ea7be"
11DEPENDS += "libxml-parser-perl"
12
13SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Simple-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "0914abddfce749453ed89b54029f2643"
16SRC_URI[sha256sum] = "b9450ef22ea9644ae5d6ada086dc4300fa105be050a2030ebd4efd28c198eb49"
17
18S = "${WORKDIR}/XML-Simple-${PV}"
19
20EXTRA_PERLFLAGS = "-I ${PERLHOSTLIB}"
21
22inherit cpan
23
24BBCLASSEXTEND = "native"