summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liberror-perl_0.17029.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/liberror-perl_0.17029.bb')
-rw-r--r--meta/recipes-devtools/perl/liberror-perl_0.17029.bb48
1 files changed, 0 insertions, 48 deletions
diff --git a/meta/recipes-devtools/perl/liberror-perl_0.17029.bb b/meta/recipes-devtools/perl/liberror-perl_0.17029.bb
deleted file mode 100644
index e54bb11ccd..0000000000
--- a/meta/recipes-devtools/perl/liberror-perl_0.17029.bb
+++ /dev/null
@@ -1,48 +0,0 @@
1SUMMARY = "Error - Error/exception handling in an OO-ish way"
2DESCRIPTION = "The Error package provides two interfaces. Firstly \
3Error provides a procedural interface to exception handling. \
4Secondly Error is a base class for errors/exceptions that can \
5either be thrown, for subsequent catch, or can simply be recorded."
6HOMEPAGE = "https://github.com/shlomif/perl-error.pm"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
11
12
13DEPENDS += "perl"
14
15RDEPENDS:${PN} += " \
16 perl-module-carp \
17 perl-module-exporter \
18 perl-module-scalar-util \
19 perl-module-overload \
20 perl-module-strict \
21 perl-module-vars \
22 perl-module-warnings \
23"
24
25RDEPENDS:${PN}-ptest += " \
26 perl-module-base \
27 perl-module-file-spec \
28 perl-module-io-handle \
29 perl-module-ipc-open3 \
30 perl-module-lib \
31 perl-module-test-more \
32"
33
34SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
35
36SRC_URI[md5sum] = "6732b1c6207e4a9a3e2987c88368039a"
37SRC_URI[sha256sum] = "1a23f7913032aed6d4b68321373a3899ca66590f4727391a091ec19c95bf7adc"
38
39S = "${WORKDIR}/Error-${PV}"
40
41inherit cpan ptest-perl
42
43do_install:prepend() {
44 # test requires "-T" (taint) command line option
45 rm -rf ${B}/t/pod-coverage.t
46}
47
48BBCLASSEXTEND = "native"