summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb')
-rw-r--r--meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb b/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
deleted file mode 100644
index 9635a5e708..0000000000
--- a/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1SUMMARY = "Security-focused ELF files checking tool"
2DESCRIPTION = "This is a small set of various PaX aware and related \
3utilities for ELF binaries. It can check ELF binary files and running \
4processes for issues that might be relevant when using ELF binaries \
5along with PaX, such as non-PIC code or executable stack and heap."
6HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9
10SRC_URI = "https://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz"
11SRC_URI[md5sum] = "a580468318f0ff42edf4a8cd314cc942"
12SRC_URI[sha256sum] = "7f4a7f8db6b4743adde7582fa48992ad01776796fcde030683732f56221337d9"
13
14RDEPENDS_${PN} += "bash"
15
16export GNULIB_OVERRIDES_WINT_T = "0"
17
18do_configure_prepend() {
19 touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README
20}
21
22do_install() {
23 oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
24}
25
26BBCLASSEXTEND = "native"
27
28inherit autotools pkgconfig
29
30PACKAGECONFIG ??= ""
31
32PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap"
33PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp"
34PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools"
35
36EXTRA_OECONF += "--enable-largefile"