summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg_0.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.6.2.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.6.2.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.6.2.bb b/meta/recipes-devtools/opkg/opkg_0.6.2.bb
new file mode 100644
index 0000000000..46be137354
--- /dev/null
+++ b/meta/recipes-devtools/opkg/opkg_0.6.2.bb
@@ -0,0 +1,75 @@
1SUMMARY = "Open Package Manager"
2SUMMARY:libopkg = "Open Package Manager library"
3SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
5DESCRIPTION = "Opkg is a lightweight package management system based on Ipkg."
6BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
7LICENSE = "GPL-2.0-or-later"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
9 file://src/opkg.c;beginline=4;endline=18;md5=d6200b0f2b41dee278aa5fad333eecae"
10
11DEPENDS = "libarchive"
12
13PE = "1"
14
15SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
16 file://opkg.conf \
17 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
18 file://run-ptest \
19 "
20
21SRC_URI[sha256sum] = "ac73a90a2549cd04948e563d915912c78e1b8ba0f43af75c5a53fcca474adbd5"
22
23# This needs to be before ptest inherit, otherwise all ptest files end packaged
24# in libopkg package if OPKGLIBDIR == libdir, because default
25# PTEST_PATH ?= "${libdir}/${BPN}/ptest"
26PACKAGES =+ "libopkg"
27
28inherit autotools pkgconfig ptest
29
30target_localstatedir := "${localstatedir}"
31OPKGLIBDIR ??= "${target_localstatedir}/lib"
32
33PACKAGECONFIG ??= "libsolv"
34
35PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,\
36 gnupg gpgme libgpg-error,\
37 ${@ "gnupg" if ("native" in d.getVar("PN")) else "gnupg-gpg"}\
38 "
39PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
40PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
41PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
42PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
43PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
44
45EXTRA_OECONF:class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"
46
47do_install:append () {
48 install -d ${D}${sysconfdir}/opkg
49 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
50 echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
51 echo "option info_dir ${OPKGLIBDIR}/opkg/info" >>${D}${sysconfdir}/opkg/opkg.conf
52 echo "option status_file ${OPKGLIBDIR}/opkg/status" >>${D}${sysconfdir}/opkg/opkg.conf
53
54 # We need to create the lock directory
55 install -d ${D}${OPKGLIBDIR}/opkg
56}
57
58do_install_ptest () {
59 sed -i -e '/@echo $^/d' ${D}${PTEST_PATH}/tests/Makefile
60 sed -i -e '/@PYTHONPATH=. $(PYTHON) $^/a\\t@if [ "$$?" != "0" ];then echo "FAIL:"$^;else echo "PASS:"$^;fi' ${D}${PTEST_PATH}/tests/Makefile
61}
62
63RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
64RDEPENDS:${PN}:class-native = ""
65RDEPENDS:${PN}:class-nativesdk = ""
66RDEPENDS:${PN}-ptest += "make binutils python3-core python3-compression bash python3-crypt python3-io"
67RREPLACES:${PN} = "opkg-nogpg opkg-collateral"
68RCONFLICTS:${PN} = "opkg-collateral"
69RPROVIDES:${PN} = "opkg-collateral"
70
71FILES:libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
72
73BBCLASSEXTEND = "native nativesdk"
74
75CONFFILES:${PN} = "${sysconfdir}/opkg/opkg.conf"