summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg_0.4.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.4.5.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.4.5.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.4.5.bb b/meta/recipes-devtools/opkg/opkg_0.4.5.bb
new file mode 100644
index 0000000000..bc948647c8
--- /dev/null
+++ b/meta/recipes-devtools/opkg/opkg_0.4.5.bb
@@ -0,0 +1,75 @@
1SUMMARY = "Open Package Manager"
2SUMMARY_libopkg = "Open Package Manager library"
3SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
5DESCRIPTION = "Opkg is a lightweight package management system based on Ipkg."
6BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
9 file://src/opkg.c;beginline=4;endline=18;md5=d6200b0f2b41dee278aa5fad333eecae"
10
11DEPENDS = "libarchive"
12
13PE = "1"
14
15SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
16 file://opkg.conf \
17 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
18 file://run-ptest \
19"
20
21SRC_URI[md5sum] = "5dc41ad37d88803b5e0f456a9c5a0811"
22SRC_URI[sha256sum] = "a1214a75fa34fb9228db8da47308e0e711b1c93fd8938cf164c10fd28eb50f1e"
23
24# This needs to be before ptest inherit, otherwise all ptest files end packaged
25# in libopkg package if OPKGLIBDIR == libdir, because default
26# PTEST_PATH ?= "${libdir}/${BPN}/ptest"
27PACKAGES =+ "libopkg"
28
29inherit autotools pkgconfig ptest
30
31target_localstatedir := "${localstatedir}"
32OPKGLIBDIR ??= "${target_localstatedir}/lib"
33
34PACKAGECONFIG ??= "libsolv"
35
36PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,\
37 gnupg gpgme libgpg-error,\
38 ${@ "gnupg" if ("native" in d.getVar("PN")) else "gnupg-gpg"}\
39 "
40PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
41PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
42PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
43PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
44PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
45
46EXTRA_OECONF += " --disable-pathfinder"
47EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"
48
49do_install_append () {
50 install -d ${D}${sysconfdir}/opkg
51 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
52 echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
53
54 # We need to create the lock directory
55 install -d ${D}${OPKGLIBDIR}/opkg
56}
57
58do_install_ptest () {
59 sed -i -e '/@echo $^/d' ${D}${PTEST_PATH}/tests/Makefile
60 sed -i -e '/@PYTHONPATH=. $(PYTHON) $^/a\\t@if [ "$$?" != "0" ];then echo "FAIL:"$^;else echo "PASS:"$^;fi' ${D}${PTEST_PATH}/tests/Makefile
61}
62
63RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
64RDEPENDS_${PN}_class-native = ""
65RDEPENDS_${PN}_class-nativesdk = ""
66RDEPENDS_${PN}-ptest += "make binutils python3-core python3-compression"
67RREPLACES_${PN} = "opkg-nogpg opkg-collateral"
68RCONFLICTS_${PN} = "opkg-collateral"
69RPROVIDES_${PN} = "opkg-collateral"
70
71FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
72
73BBCLASSEXTEND = "native nativesdk"
74
75CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"