summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg_0.1.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.1.8.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.1.8.bb13
1 files changed, 4 insertions, 9 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.1.8.bb b/meta/recipes-devtools/opkg/opkg_0.1.8.bb
index 6815474207..18cf0428ce 100644
--- a/meta/recipes-devtools/opkg/opkg_0.1.8.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.1.8.bb
@@ -13,7 +13,7 @@ SRC_URI = "http://opkg.googlecode.com/files/opkg-${PV}.tar.gz \
13 file://headerfix.patch \ 13 file://headerfix.patch \
14" 14"
15 15
16PR = "r3" 16PR = "r4"
17 17
18PACKAGES =+ "libopkg${PKGSUFFIX}-dev libopkg${PKGSUFFIX} update-alternatives-cworth${PKGSUFFIX}" 18PACKAGES =+ "libopkg${PKGSUFFIX}-dev libopkg${PKGSUFFIX} update-alternatives-cworth${PKGSUFFIX}"
19 19
@@ -26,11 +26,6 @@ do_install_append() {
26 install -d ${D}${localstatedir}/lib/opkg 26 install -d ${D}${localstatedir}/lib/opkg
27} 27}
28 28
29# Define a variable to allow distros to run configure earlier.
30# (for example, to enable loading of ethernet kernel modules before networking starts)
31OPKG_INIT_POSITION = "98"
32OPKG_INIT_POSITION_slugos = "41"
33
34pkg_postinst_${PN} () { 29pkg_postinst_${PN} () {
35#!/bin/sh 30#!/bin/sh
36if [ "x$D" != "x" ]; then 31if [ "x$D" != "x" ]; then
@@ -38,9 +33,9 @@ if [ "x$D" != "x" ]; then
38 # this happens at S98 where our good 'ole packages script used to run 33 # this happens at S98 where our good 'ole packages script used to run
39 echo "#!/bin/sh 34 echo "#!/bin/sh
40opkg-cl configure 35opkg-cl configure
41rm -f /${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure 36rm -f /${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
42" > $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure 37" > $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
43 chmod 0755 $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure 38 chmod 0755 $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
44fi 39fi
45 40
46update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100 41update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100