summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.14.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.14.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.14.bb b/meta/recipes-devtools/nasm/nasm_2.14.bb
new file mode 100644
index 0000000000..231d4e6b15
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.14.bb
@@ -0,0 +1,25 @@
1SUMMARY = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
5
6SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2"
7
8SRC_URI[md5sum] = "238a240d3f869a52f8ac38ee3f8faafa"
9SRC_URI[sha256sum] = "d43cfd27cad53d0c22a9bf9702e9dffcc7018a0df21d15b92c56d250d747c744"
10
11inherit autotools-brokensep
12
13do_configure_prepend () {
14 if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
15 mv ${S}/aclocal.m4 ${S}/acinclude.m4
16 fi
17}
18
19do_install() {
20 oe_runmake 'DESTDIR=${D}' install
21}
22
23BBCLASSEXTEND = "native"
24
25DEPENDS = "groff-native"